summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autodoc-typehints
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-08 09:59:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-08 09:59:13 +0000
commit31a02d889028bf30f7b376b935aa05c2140d3c66 (patch)
tree6b211d58d5072baba31037fda71f6f421c38e5c8 /dev-python/sphinx-autodoc-typehints
parent8f53b8011f9c960a02775a71c3805e13e72237fd (diff)
gentoo auto-resync : 08:02:2024 - 09:59:13
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest2
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.0.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 92a4ff5ee96b..bd050a40c92e 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1,5 +1,7 @@
DIST sphinx_autodoc_typehints-1.25.2.tar.gz 37173 BLAKE2B cec43a8008e84cbc0cc8f1950d8c8b3aceec139f2c9b8de310620fbd7deab021ebc51caa0ec80421d821287c8f9c304102141eda9e1123496d710ce3d87590a7 SHA512 42d14b17e05c46d65fb363f6b640515e1847d1d1b13b9d4707c0e64002e01d974a4c8d06d90f938a149704641926b08755a8c9c1f84883b5841192c7330660a3
DIST sphinx_autodoc_typehints-1.25.3.tar.gz 37709 BLAKE2B 338a0479af929977af7d3d3b9797e2806f8606c85cf1db182f87cf6d25adafeaf8c4941bc1770f9c55a54227e1132fd424ed80f5efc654f34c7e4b61724ef553 SHA512 e00ed10267605d8d96b159788297ec565f9dc46b2a446136067e1c5d0fed0d276245c052e3121e79fdf3a0aff81e91769728bb829ce07b252d7284af3378fe69
+DIST sphinx_autodoc_typehints-2.0.0.tar.gz 37951 BLAKE2B 55fc5bd4a430095b9b80b7313da96ac177f55d8e31068ded7c740cc2757580b611bfdb0aa53cc8344564cf01b052518854ea040a70ea568bd098505f8c2dfca8 SHA512 e37839b8f9393334f43b2b97f3d9ade4a2e11182e634c4ee37a916bcf4425c624376edcd3b25b054a23e15624393e3a79fdbc1775f6b3808e09bc8a85a2262d5
EBUILD sphinx-autodoc-typehints-1.25.2.ebuild 986 BLAKE2B 2246e416aeb091f7b8d2115466ff84fac33c2785828cb18fdadef2d967c9114a57d962aa1fddd387f29e0f04d21b9479b3d8c800e4ac7cd0e4d2108fa16f6b93 SHA512 846d85359413d4498c31f80eca1bfe01a40b47beee6e68380d1aea658062dc4d9eec7284677e391c9a45273025eca4d1293dc1ae438a31a195549bd455f3db5b
EBUILD sphinx-autodoc-typehints-1.25.3.ebuild 993 BLAKE2B b29098e7aae4c944614c927882c941d6d0da29cece54f5afc0c98a290f43689df28af42339872d8721aa3c0f9ecf7b8db7aa52deddddde56908413c31f3b5925 SHA512 642b662dc37416552e2fa09914f07ee6995194428eade005bef5e954c45549906693edf4cdb7b05ec77c9f34f20224bfc9f2101ae8f517062128f33b2437349a
+EBUILD sphinx-autodoc-typehints-2.0.0.ebuild 993 BLAKE2B b29098e7aae4c944614c927882c941d6d0da29cece54f5afc0c98a290f43689df28af42339872d8721aa3c0f9ecf7b8db7aa52deddddde56908413c31f3b5925 SHA512 642b662dc37416552e2fa09914f07ee6995194428eade005bef5e954c45549906693edf4cdb7b05ec77c9f34f20224bfc9f2101ae8f517062128f33b2437349a
MISC metadata.xml 682 BLAKE2B f8b48894f28411a17c73956bb75d43906c893b33d3dc611dfcc46e7a71ac43824aa54f660ab4f49c9870248b2b9ff405a2a3229f92975337e69201868eed3378 SHA512 87a0ea2b2e4cb2b5f0d1593b2c4bd96b46dabb8baae71a6ba18cfd83dedb2a1d5f0ae0f8711144967a5d44015e9ae7ca013dc0aa54e20604633ae062d95649ef
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.0.0.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.0.0.ebuild
new file mode 100644
index 000000000000..17aaf83155a2
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-7.1.2[${PYTHON_USEDEP}]
+"
+# skipping optional test dep on dev-python/nptyping as that package
+# is horribly broken and on its way out
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/sphobjinv-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)