summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autoapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-29 09:53:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-29 09:53:01 +0100
commitf7436a5ce1c11f1c33cd09dd757f768cd07b19fd (patch)
tree6296aa82e3fe61664c80ba6cdd0d7cc410a1c2ad /dev-python/sphinx-autoapi
parent80422eacf48ea819f1aeefc7a809533aa63fb85a (diff)
gentoo auto-resync : 29:03:2023 - 09:53:01
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/Manifest2
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-2.1.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index 3076dcdd07dc..98448b0ad3fd 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1,5 +1,7 @@
DIST sphinx-autoapi-2.0.0.gh.tar.gz 86051 BLAKE2B af6c2f997e7e018304c5f19d978fc87fa853d876781930c1220e8e823a078c80c86851a141ed01d7ab94fd76d747e8dfd7462dd5ccab84127f1c95d225324a92 SHA512 7188ed167de808028b2ac603abb6a136584698a1df4882755b80609f4760dab818cec5f4684bf5d16afc2ae1be112ecb96c7f02f989fcb67937c19c045f45b81
DIST sphinx-autoapi-2.0.1.gh.tar.gz 85974 BLAKE2B 5beea907901603a665367c244188f847fcc59f889df5da4e27dba39f36c9714347dab1e867d3bbed0fb44139eb1f77863178a0c831e06a6d373211892e8ce6ab SHA512 b7301a86fa6ebde80fd6289e92e2e9149323044f6db34e39305541ccb4bcb136a777c8e38c152f7536435290c86a0543d51c14290fbdfeb7b13805f711e00a80
+DIST sphinx-autoapi-2.1.0.gh.tar.gz 84842 BLAKE2B 0020640833039c5c15babeb2ed37bffa9a836209e51bb5d4873ccd34527f6b652516ceed95d2e823a9394e6154ea36311a78fcf0645723c3060a6eb7f31b0668 SHA512 4228c0d7c91a89933101d1c02689f1e25c453ead66814f8653f1e20b6330a20913b8d98573b3afb5459be972b73535cbe81fd267e721bedfb78a2de4673fa9e2
EBUILD sphinx-autoapi-2.0.0.ebuild 1366 BLAKE2B aed34cef0c018222e1ef0bdd56499807b7c2ef39f9807e5f6400368114bb235642b27a4109c31c32fe0f6a0717199910594e9978c79facb6e64e4ea97060c7f9 SHA512 90e9e0220601ed8909a51465ca887f4780ab13dbcd3aa1c847d3217c493b961822a9a05bc0dc4601564e3ee076a6c8083a235eaab90d8fd021e1b2121905884a
EBUILD sphinx-autoapi-2.0.1.ebuild 1526 BLAKE2B 7be2053cdf6deb66f7e2bad3b537f2cea637c1e35f555906e75fda366fbd551a73c99da339641291314f4c011d97d0526a4f143d0729c299886ff5ada13c01a8 SHA512 64417ad80f02bc2c4e92d48a2d2cf9182c3659ab84ad4d320e172c92789664953e596d7f7efe6d05e676e9243934c0ead7f962247dea2a6575bb272b5f43404c
+EBUILD sphinx-autoapi-2.1.0.ebuild 1565 BLAKE2B f253e910ce0dddef29f5c85521ac681d20cdd27ff9497a7f07cc0ebd48929ec3941ab9d5e947b5a8c8e87263c4daa3ca4ce26b22cf537259284208d10a954e3a SHA512 9365eba871b00a86c292f1857d06b18c8207fbcebf7794960c02ff4b7e016d2c25ba1d720f2eef46fed9c46c967f9811bde7bca8211d0069244f181f2fec9b7b
MISC metadata.xml 769 BLAKE2B 6f85e487a2d2def289bb54a6addc2338bb8af85b323ec1c95851945f9c407ec22bfadd8079ac8b6e00cfbc85caa0e2b09d82329f1f87a365fc44b69c7bcd9a20 SHA512 68f02a5f98234c2a5cb15aa04ce90077b154a7e3a7a69dc0a1d0a6b5c7b42c60624878a7e2fff1576c8b586fc15e7ef042942274d4e8473835bb3d8bfdbd8393
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-2.1.0.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-2.1.0.ebuild
new file mode 100644
index 000000000000..b05c3d17081f
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-2.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+# sdist is missing docs, as of 2.1.0
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/astroid[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-5.2.0[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+# Test requires pypi download w/ internet: https://github.com/readthedocs/sphinx-autoapi/issues/329
+EPYTEST_DESELECT=(
+ tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample-override_conf2-AutoAPI
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_test() {
+ # https://github.com/readthedocs/sphinx-autoapi/issues/368
+ if has_version "<dev-python/sphinx-6.0"; then
+ EPYTEST_DESELECT+=(
+ tests/python/test_pyintegration.py::TestPositionalOnlyArgumentsModule::test_integration
+ tests/python/test_pyintegration.py::TestPy3Module::test_annotations
+ tests/python/test_pyintegration.py::TestAnnotationCommentsModule::test_integration
+ )
+ fi
+
+ distutils-r1_python_test
+}