summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autoapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-29 03:21:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-29 03:21:54 +0100
commit62ea91b40c7650011a72ed2443f76b88b06123fe (patch)
tree1e60e1f2ac4a793b10db166d55ffadb46eeda0ff /dev-python/sphinx-autoapi
parentbd7d7f7f69423122e08209eefb1a8fa1d363e35e (diff)
gentoo auto-resync : 29:09:2022 - 03:21:54
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/Manifest2
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index 5e2d3a4ff682..83137b4e7d28 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-autoapi-1.9.0.gh.tar.gz 84730 BLAKE2B 31547c0dee076736d65867d9856e713581c440d2b1f01b7ebcbe09b31a7bf2979346bcbe18d6064fd5656b7d7dab9149c67fe79f0db7e5757c2581370c11a8cd SHA512 f098f474d9821c974c2ede77de30f3317c87cb87ec00b7a1c021add1d07a1ed59fa3b4165edf2b7f5165004ba9c717394962154098bc89b52989d0e604c542f1
+DIST sphinx-autoapi-2.0.0.gh.tar.gz 86051 BLAKE2B af6c2f997e7e018304c5f19d978fc87fa853d876781930c1220e8e823a078c80c86851a141ed01d7ab94fd76d747e8dfd7462dd5ccab84127f1c95d225324a92 SHA512 7188ed167de808028b2ac603abb6a136584698a1df4882755b80609f4760dab818cec5f4684bf5d16afc2ae1be112ecb96c7f02f989fcb67937c19c045f45b81
EBUILD sphinx-autoapi-1.9.0.ebuild 1065 BLAKE2B 88f28fe9b865a202421fb2ed3f6e28ddc40b5fd0dc565934ead1c53db8a34e96490645942915e99bc7fc251b95ea1d71dac7a142c9573f56947ba6cd69834ba4 SHA512 99fc2c264bcfa59e49516e857179666616521c83c135d73360d920c6bce014186869184dd40e633d24833542c78b0d457d5b74b31650bae44aff392ba5f2eb49
+EBUILD sphinx-autoapi-2.0.0.ebuild 1075 BLAKE2B 81763ca798724ba0f2e502edbb82adf35a7b0fd1560fe4db135aea34ed54c8b584e1ad0bf173142901ad820bd1ae846011172181517f14338f217b9bccd87ebd SHA512 6a66a48b3dd8389aa0f3f6d77901e829d5f9bbb56d54ee9d983603be4ca4d16c9bad02f98c28f5a3840bb1265eacf686461ea3b98f01cf20352a62d32b3ebe33
MISC metadata.xml 769 BLAKE2B 6f85e487a2d2def289bb54a6addc2338bb8af85b323ec1c95851945f9c407ec22bfadd8079ac8b6e00cfbc85caa0e2b09d82329f1f87a365fc44b69c7bcd9a20 SHA512 68f02a5f98234c2a5cb15aa04ce90077b154a7e3a7a69dc0a1d0a6b5c7b42c60624878a7e2fff1576c8b586fc15e7ef042942274d4e8473835bb3d8bfdbd8393
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild
new file mode 100644
index 000000000000..ed1cb2fd23fd
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-2.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/astroid[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-4.0[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+# Test requires pypi download w/ internet: https://github.com/readthedocs/sphinx-autoapi/issues/329
+EPYTEST_DESELECT=(
+ tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample-override_conf2-AutoAPI
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc