summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-29 13:40:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-29 13:40:31 +0100
commite745e1d281540da525df5eaae0904b62bc27852f (patch)
treefe71391505cd5188d417ddc468859a54f0c648ae /dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild
parent05f2a11918a15ef57166e74d69d6c4737673e75c (diff)
gentoo auto-resync : 29:06:2023 - 13:40:31
Diffstat (limited to 'dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild')
-rw-r--r--dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild b/dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild
new file mode 100644
index 000000000000..2b28e7ab59e5
--- /dev/null
+++ b/dev-python/sphinx-argparse/sphinx-argparse-0.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension that automatically documents argparse commands and options"
+HOMEPAGE="https://pypi.org/project/sphinx-argparse/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest