summaryrefslogtreecommitdiff
path: root/dev-python/sortedcollections
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/sortedcollections
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sortedcollections')
-rw-r--r--dev-python/sortedcollections/Manifest3
-rw-r--r--dev-python/sortedcollections/metadata.xml15
-rw-r--r--dev-python/sortedcollections/sortedcollections-0.5.3.ebuild21
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sortedcollections/Manifest b/dev-python/sortedcollections/Manifest
new file mode 100644
index 000000000000..3543936f5079
--- /dev/null
+++ b/dev-python/sortedcollections/Manifest
@@ -0,0 +1,3 @@
+DIST sortedcollections-0.5.3.tar.gz 7021 BLAKE2B fdef18b938502f0fc7ce1683977b0982c23aa915d79b6bac30cf9cd74aa19af695f2aacb658a8411304497f28d270e9ba95bbdbcc47220f0302cd376edf312d9 SHA512 e0076017d1a97d7dc18b02bc4e3739c535ab001260be739fab2784cb58deac4323957fe21b4c679f55a790d864ca696695a603298709225b04eae740d859ab28
+EBUILD sortedcollections-0.5.3.ebuild 572 BLAKE2B c96c38362bec78d965b3a094de305b3db9b79b0fd859b96121811693674958163c2f61809cbae9bb2dda9d5feca33c57bbb5fda3d6f1852d5fd4a1120555c009 SHA512 c164b32b7e4754f37037bc57e5f6ca61b9ae5573a4075bd4c7c97985704da1de6a2258b96fa690ff02a37835500dad3346146a6890b933c0868f56588fb32839
+MISC metadata.xml 498 BLAKE2B 5638984052d38b48773ba3efad23de34d7d22e5de6ab570a0f1c8494918b0f331b2a3f7cd72d976de9d1d24ae623af07370bf9daf6833792019472a1a23c2fc0 SHA512 d332e588cdf6194708c1e3f00e9e8159669eb36cb21b4c6eed8e5af44f09f7e71f12fe437ce889b96599994f7a9c9d7c4fa6642c2ab74cedb0490d21a3165d21
diff --git a/dev-python/sortedcollections/metadata.xml b/dev-python/sortedcollections/metadata.xml
new file mode 100644
index 000000000000..4c79be884169
--- /dev/null
+++ b/dev-python/sortedcollections/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Pure python sorted collection library.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">sortedcollections</remote-id>
+ <remote-id type="github">grantjenks/sortedcollections</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sortedcollections/sortedcollections-0.5.3.ebuild b/dev-python/sortedcollections/sortedcollections-0.5.3.ebuild
new file mode 100644
index 000000000000..f979144c81c0
--- /dev/null
+++ b/dev-python/sortedcollections/sortedcollections-0.5.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to sort collections and containers"
+HOMEPAGE="http://www.grantjenks.com/docs/sortedcontainers/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"