summaryrefslogtreecommitdiff
path: root/dev-python/socketio-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/socketio-client
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/socketio-client')
-rw-r--r--dev-python/socketio-client/Manifest3
-rw-r--r--dev-python/socketio-client/metadata.xml15
-rw-r--r--dev-python/socketio-client/socketio-client-0.6.6.ebuild45
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/socketio-client/Manifest b/dev-python/socketio-client/Manifest
new file mode 100644
index 000000000000..b19dd3af3b85
--- /dev/null
+++ b/dev-python/socketio-client/Manifest
@@ -0,0 +1,3 @@
+DIST socketio-client-0.6.6.tar.gz 21829 BLAKE2B 72e47f9aa4bae06767aa1860fc7d57f7f2ae78dd037e46aa50a8672f4e168982d6e602ed8f80f203081e5747cacb0f6fa2959311271bc578c1b8b5bf70ec506a SHA512 aa21d31bf9e9062578fc6892a7624ea41ef3437eff132ff3ef2829a589c0fd19953fc514ab05161a32d06578708fb7f41b2f636d3d60a2700094e676d72cee47
+EBUILD socketio-client-0.6.6.ebuild 1448 BLAKE2B 71563dd4161bb90ce768e3bdced2e828c10f18d33b9e39f708efa818fe53efbc0e6e2301418b938558f2b58a9f8bde4be9e5c5ae6e2900c5844895106b6b811e SHA512 280755d8e71fc71c178d40de696a62b2a763cd571eb5f437a12f5cb3ecae22b7626cdcbd1623d17232024406e90deb8ee4d8c6fb2d602eb22adfa5031348f28e
+MISC metadata.xml 466 BLAKE2B aeae4a6f57347d31b7eed388cc7beeb819174f5f07b438a418f99532eb01ae092e6fa9a5758512de10f96f9e8aecef0e234d6e893ba39a353ddb1e42f1574b41 SHA512 a5d48ac121de3b0334d12ff4e472aa04be849f87f8ef39222a5a112674d36390d1ca69936d675cb7a42d11e73cdc5019540091ac64b727842d515b2c96b68c09
diff --git a/dev-python/socketio-client/metadata.xml b/dev-python/socketio-client/metadata.xml
new file mode 100644
index 000000000000..3d1c3fb2038d
--- /dev/null
+++ b/dev-python/socketio-client/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">socketIO-client</remote-id>
+ <remote-id type="github">invisibleroads/socketIO-client</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/socketio-client/socketio-client-0.6.6.ebuild b/dev-python/socketio-client/socketio-client-0.6.6.ebuild
new file mode 100644
index 000000000000..4ddc8b6e4e17
--- /dev/null
+++ b/dev-python/socketio-client/socketio-client-0.6.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="socketIO-client"
+REPO_PN="socketIO_client"
+DESCRIPTION="A socket.io client library for Python"
+HOMEPAGE="https://github.com/invisibleroads/socketIO-client/ https://pypi.org/project/socketIO-client/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${REPO_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${REPO_PN}-${PV}"
+
+python_test() {
+ # https://github.com/invisibleroads/socketIO-client/issues/90
+ # This runs the suite but has nill output to the screen
+ # The bug filed will hopefully yield a more conventional testsuite
+
+ # The import of SocketIO need be made with abs path to run the tests
+ sed -e 's:from .. import:from socketIO_client import:' \
+ -i ${REPO_PN}/tests/__init__.py || die
+
+ "${PYTHON}" ${REPO_PN}/tests/__init__.py || die "Tests failed under ${EPYTHON}"
+
+ # Return to original form for final install
+ sed -e 's:from socketIO_client import:from .. import:' \
+ -i ${REPO_PN}/tests/__init__.py || die
+}