summaryrefslogtreecommitdiff
path: root/dev-python/sniffio/sniffio-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/sniffio/sniffio-1.2.0.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/sniffio/sniffio-1.2.0.ebuild')
-rw-r--r--dev-python/sniffio/sniffio-1.2.0.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-python/sniffio/sniffio-1.2.0.ebuild b/dev-python/sniffio/sniffio-1.2.0.ebuild
index f6f3ddbd3664..13064b3ad091 100644
--- a/dev-python/sniffio/sniffio-1.2.0.ebuild
+++ b/dev-python/sniffio/sniffio-1.2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Sniff out which async library your code is running under"
@@ -20,11 +20,7 @@ KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86"
distutils_enable_tests pytest
-python_test() {
- local deselect=(
- # curio is not packaged
- sniffio/_tests/test_sniffio.py::test_curio
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
+EPYTEST_DESELECT=(
+ # curio is not packaged
+ sniffio/_tests/test_sniffio.py::test_curio
+)