summaryrefslogtreecommitdiff
path: root/dev-python/snakeoil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/snakeoil
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/snakeoil')
-rw-r--r--dev-python/snakeoil/Manifest6
-rw-r--r--dev-python/snakeoil/metadata.xml12
-rw-r--r--dev-python/snakeoil/snakeoil-0.7.4.ebuild35
-rw-r--r--dev-python/snakeoil/snakeoil-0.7.5.ebuild35
-rw-r--r--dev-python/snakeoil/snakeoil-9999.ebuild33
5 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/snakeoil/Manifest b/dev-python/snakeoil/Manifest
new file mode 100644
index 000000000000..5082c0c34942
--- /dev/null
+++ b/dev-python/snakeoil/Manifest
@@ -0,0 +1,6 @@
+DIST snakeoil-0.7.4.tar.gz 301878 BLAKE2B ec40ba5921e6edd33cb9dd80a284dee0cc8940dbb71f7bb6390d7008c0ca3a657b70be225955d7d6b99aa9e8c9d16dc926560bab17ac917ea8f71f97a1cf4644 SHA512 b3ae2223a267fa74699664470a4c4f6888cf2b68e688fe61d3acca85e00a138c3a037482ef304ee26f326cba252b473d265dcd72d0e0ab5723f4b0ed6e5e04ce
+DIST snakeoil-0.7.5.tar.gz 303270 BLAKE2B 66d00cf50c8efd73d765904b9c7e8ba725caef9608e68f5707ddc09358507fe64214af73b333ec5bee2ef950d8dbad474cb5d9e4412757bc3c82d75909f6fc23 SHA512 b9f6efce2e3f5df83248b1faa84493aa11d8a08935e3991a56daace96e0de39dd5c7d25a69a4394f7ba163de78ed56a2619ef64c33114128fc02052d676a86a5
+EBUILD snakeoil-0.7.4.ebuild 937 BLAKE2B a69adf1930195a590dd831129b17f20cb80584772bec618793af405bd2e7f1d13f267db3e6634846d5d88db1692e77e3bf5d4c9dba08e5845d9ce228ee501894 SHA512 f47c6e9dc49a0221c082da07d2e69e00bf1a3ddf3ad59afbe82087369bd9e3e9bb4ef0b99c5871d9af6a122ca3b7ee24b10ad8d1f31c52bdb5c356960c65c76f
+EBUILD snakeoil-0.7.5.ebuild 968 BLAKE2B 0f23a9ca7ddd281cffcdfdd09ac5e92dc6b37076520c91a54c6749683a5469212ef51517708ee13c7f79a81df8a6089b3b0aef528702b597e409d93e0134f1c3 SHA512 30a47abfd5d4261430028c92897866894de48cea1cd973190342fdc3fcc300aee24f1579c85825c1aff6ef385ecc3577c61a0e56b6db165773ec38177d872f0f
+EBUILD snakeoil-9999.ebuild 892 BLAKE2B 0e8f5d786e969ea26cda8eeb261af331aee3a085791fa62bca0d4fc44a4da430a754ad7e6ef6a5247f7788701152483ecbd6c18ff11e23cf2671d5b7303cb785 SHA512 e97711f75b09c5e4fce4e9549bb17256e43b5a0c7d13001d13b2b9d79218bc18b9dcd719f6b24b152115bb5668d83c1dda9ed9f02178bc74a2a93d822e806b63
+MISC metadata.xml 385 BLAKE2B 7e7195d4876c5cb5db98288566121559c8bd9208138fbd211edea15b324acb11d09a2bdd96c0200554d7e9c734202c7fd341f0d134f271c82dbfdfe75e5774f5 SHA512 32645380ddb0bd1edca1895714aeaef3e0c61c04cbacb50a414c2fd26b6978c8ea83b3c420538cadebf3a631b5aec2e9e3fc0dab98d1e1a99cfbad33b8d58715
diff --git a/dev-python/snakeoil/metadata.xml b/dev-python/snakeoil/metadata.xml
new file mode 100644
index 000000000000..9defaede9abc
--- /dev/null
+++ b/dev-python/snakeoil/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pkgcore/snakeoil</remote-id>
+ <remote-id type="pypi">snakeoil</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/snakeoil/snakeoil-0.7.4.ebuild b/dev-python/snakeoil/snakeoil-0.7.4.ebuild
new file mode 100644
index 000000000000..c037456a6ebe
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.7.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+[[ ${PV} == 9999 ]] && DEPEND+=" $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' 'python3*')"
+
+python_configure_all() {
+ # disable snakeoil 2to3 caching
+ unset PY2TO3_CACHEDIR
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/snakeoil/snakeoil-0.7.5.ebuild b/dev-python/snakeoil/snakeoil-0.7.5.ebuild
new file mode 100644
index 000000000000..38a023db443b
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.7.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ SRC_URI="https://github.com/pkgcore/snakeoil/releases/download/v${PV}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+[[ ${PV} == 9999 ]] && DEPEND+=" $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' 'python3*')"
+
+python_configure_all() {
+ # disable snakeoil 2to3 caching
+ unset PY2TO3_CACHEDIR
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/snakeoil/snakeoil-9999.ebuild b/dev-python/snakeoil/snakeoil-9999.ebuild
new file mode 100644
index 000000000000..431ad815edf4
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ SRC_URI="https://github.com/pkgcore/snakeoil/releases/download/v${PV}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+[[ ${PV} == 9999 ]] && DEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}