summaryrefslogtreecommitdiff
path: root/dev-python/snakeoil/snakeoil-0.10.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-30 15:24:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-30 15:24:40 +0100
commit31459e63971ac3b08706bba949851d93c45043c3 (patch)
treef50f9db11363f1369a1aead733baccaf2842b673 /dev-python/snakeoil/snakeoil-0.10.1.ebuild
parenteba9b95ba8976f2938bafa5789c1b50611bb3459 (diff)
gentoo auto-resync : 30:09:2022 - 15:24:40
Diffstat (limited to 'dev-python/snakeoil/snakeoil-0.10.1.ebuild')
-rw-r--r--dev-python/snakeoil/snakeoil-0.10.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/snakeoil/snakeoil-0.10.1.ebuild b/dev-python/snakeoil/snakeoil-0.10.1.ebuild
new file mode 100644
index 000000000000..a2c4c4cf4928
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.10.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD BSD-2 MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest