summaryrefslogtreecommitdiff
path: root/dev-python/smartypants
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/smartypants
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/smartypants')
-rw-r--r--dev-python/smartypants/Manifest3
-rw-r--r--dev-python/smartypants/smartypants-2.0.1-r1.ebuild31
-rw-r--r--dev-python/smartypants/smartypants-9999.ebuild8
3 files changed, 37 insertions, 5 deletions
diff --git a/dev-python/smartypants/Manifest b/dev-python/smartypants/Manifest
index 372e6e519610..3dfcd4ad85ab 100644
--- a/dev-python/smartypants/Manifest
+++ b/dev-python/smartypants/Manifest
@@ -1,4 +1,5 @@
DIST smartypants-2.0.1.tar.gz 24152 BLAKE2B 258c9692eec675054dc31f760cf3a9fc3995683d7a15fc549fb390611761c0b09f73e077f5917f9f071a8fc1ae3f06e36f745fdc0e2c368f465e29f6ce51457f SHA512 d47a866a5478c3520251f87a93a468a5eea10318b24b2e8d4bc918d533b5a5789aa56d3a8d5fb8ccff9572fb63e5b6f2eafc44f93fb57a19e6621ebef5d64d9d
+EBUILD smartypants-2.0.1-r1.ebuild 781 BLAKE2B bc1b39dc4d11c02a138c47c34ddca756cc5d84154cef879b1161986688cbd3db1b6c6525993f7f6afc2bc440239d3a9b3a8a9d23fe66f96caf2d04ee8936ba53 SHA512 bbf11645cd3f53d16b37faa859f9f58fc1d18d9b170a20831e646d045c575d0b5fa057dc15c8efb376a92520743d5e0718a85705073759c26e95b62ef16db004
EBUILD smartypants-2.0.1.ebuild 769 BLAKE2B 25cd50dfbd78d34ea27b20865b9db0bdb61dcec3757fa539e20b36bbe1b9b8456f4665a1364d1effae782c066bb455713461dbdab0022ab7e25c27398d6484d3 SHA512 04e02eb254ed92831fa75fd0e21e7f93aca4c69f4667c7438a8bc14f682106ccac64b52f5b6ddc17a1f7c43b8ba8b7dc579626ee990af5f40bbb63b3214fafe4
-EBUILD smartypants-9999.ebuild 757 BLAKE2B 1b3a74116cd9100cb8e238626653a98aa2de7dd1c2a2d408904e736b2650bbe2f0b70e12f9dc3c60aa5fb9e60758d5bcbee3ca981f3bd876a0d170239d50aff8 SHA512 b91692da182232108d69ce4a9b090bfb2c55ca2b397de1b2a225ace059a1c8f3098a3d06881fbd8767c2131589c8f968e585a391a717e2094da46971288ff9b7
+EBUILD smartypants-9999.ebuild 781 BLAKE2B bc1b39dc4d11c02a138c47c34ddca756cc5d84154cef879b1161986688cbd3db1b6c6525993f7f6afc2bc440239d3a9b3a8a9d23fe66f96caf2d04ee8936ba53 SHA512 bbf11645cd3f53d16b37faa859f9f58fc1d18d9b170a20831e646d045c575d0b5fa057dc15c8efb376a92520743d5e0718a85705073759c26e95b62ef16db004
MISC metadata.xml 533 BLAKE2B fbdcaba39094feabf10101304a6ad33c261042a49adbfb0610f3c3c0c3cb210d16f5cf7b7033d0092b567029194b40af3470bab472d068883e4800c550c72d30 SHA512 72b1d23d6a0e0b25679cf5de859398606004891308a316e549cac1c615381e3c89bcb79428e21346856cddbd28740b9423abefbe9b55b397dbaf41a56d7763df
diff --git a/dev-python/smartypants/smartypants-2.0.1-r1.ebuild b/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..c5c6b78000bf
--- /dev/null
+++ b/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{6..10} )
+
+MY_PN="${PN}.py"
+MY_P="${MY_PN}-${PV}"
+
+inherit distutils-r1
+
+DESCRIPTION="ASCII quote-dot-dash to HTML entity converter"
+HOMEPAGE="https://pypi.python.org/pypi/smartypants/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/leohemsted/smartypants.py.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/leohemsted/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+distutils_enable_sphinx docs
+distutils_enable_tests setup.py
diff --git a/dev-python/smartypants/smartypants-9999.ebuild b/dev-python/smartypants/smartypants-9999.ebuild
index 418910a52b87..c5c6b78000bf 100644
--- a/dev-python/smartypants/smartypants-9999.ebuild
+++ b/dev-python/smartypants/smartypants-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{6..10} )
-DISTUTILS_USE_SETUPTOOLS=no
MY_PN="${PN}.py"
MY_P="${MY_PN}-${PV}"
@@ -20,7 +20,7 @@ if [[ ${PV} = 9999* ]]; then
inherit git-r3
else
SRC_URI="https://github.com/leohemsted/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
S="${WORKDIR}/${MY_P}"
fi