summaryrefslogtreecommitdiff
path: root/dev-python/smartypants
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/smartypants
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/smartypants')
-rw-r--r--dev-python/smartypants/Manifest4
-rw-r--r--dev-python/smartypants/metadata.xml15
-rw-r--r--dev-python/smartypants/smartypants-2.0.1.ebuild32
-rw-r--r--dev-python/smartypants/smartypants-9999.ebuild32
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/smartypants/Manifest b/dev-python/smartypants/Manifest
new file mode 100644
index 000000000000..5e9086695be9
--- /dev/null
+++ b/dev-python/smartypants/Manifest
@@ -0,0 +1,4 @@
+DIST smartypants-2.0.1.tar.gz 24152 BLAKE2B 258c9692eec675054dc31f760cf3a9fc3995683d7a15fc549fb390611761c0b09f73e077f5917f9f071a8fc1ae3f06e36f745fdc0e2c368f465e29f6ce51457f SHA512 d47a866a5478c3520251f87a93a468a5eea10318b24b2e8d4bc918d533b5a5789aa56d3a8d5fb8ccff9572fb63e5b6f2eafc44f93fb57a19e6621ebef5d64d9d
+EBUILD smartypants-2.0.1.ebuild 714 BLAKE2B 8943a6ae8fd0a47683ecc58ae234ddeab1f48f2b82c89779406b181b4e203207371821c8d79d232d33a88f3505014bd042a4e1fffa1df28254de419bdddcd664 SHA512 b5efcac779dfccd5c3e965550a7a4ab4c14bc55c0202a50c51ad822e32dac983bddd2dfa52430fe5fdad830c9281f7bd73345dc4cf220477f64f075eb175167f
+EBUILD smartypants-9999.ebuild 714 BLAKE2B 8943a6ae8fd0a47683ecc58ae234ddeab1f48f2b82c89779406b181b4e203207371821c8d79d232d33a88f3505014bd042a4e1fffa1df28254de419bdddcd664 SHA512 b5efcac779dfccd5c3e965550a7a4ab4c14bc55c0202a50c51ad822e32dac983bddd2dfa52430fe5fdad830c9281f7bd73345dc4cf220477f64f075eb175167f
+MISC metadata.xml 476 BLAKE2B 8208a4c59e18ba68cf03e6daa1c1a577fb79d0a8122ee2a8a2eecd0a432daba6055935d5552596b1ffadbf2b6ecd9443d45255339137f7f77436fa48fd19d9ae SHA512 e0f66a1b37803b4379558b451fe4d390d9de52f18db2010932be7553323a45f2db5be2b555c1540ec46998e295df1a54ca79bdc32726135dccab18c74b1fbc77
diff --git a/dev-python/smartypants/metadata.xml b/dev-python/smartypants/metadata.xml
new file mode 100644
index 000000000000..21caf30ef387
--- /dev/null
+++ b/dev-python/smartypants/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>nerdboy@gentoo.org</email>
+ <name>Steve Arnold</name>
+</maintainer>
+<longdescription lang="en">
+ smartypants is a Python fork of SmartyPants (wha?)
+</longdescription>
+<upstream>
+ <remote-id type="pypi">smartypants</remote-id>
+ <remote-id type="github">leohemsted/smartypants.py</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/smartypants/smartypants-2.0.1.ebuild b/dev-python/smartypants/smartypants-2.0.1.ebuild
new file mode 100644
index 000000000000..0624ab1574f9
--- /dev/null
+++ b/dev-python/smartypants/smartypants-2.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+MY_PN="${PN}.py"
+MY_P="${MY_PN}-${PV}"
+
+inherit distutils-r1
+
+DESCRIPTION="ASCII quote-dot-dash to HTML entity converter"
+HOMEPAGE="https://pypi.python.org/pypi/smartypants/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/leohemsted/smartypants.py.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/leohemsted/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+distutils_enable_sphinx docs
diff --git a/dev-python/smartypants/smartypants-9999.ebuild b/dev-python/smartypants/smartypants-9999.ebuild
new file mode 100644
index 000000000000..0624ab1574f9
--- /dev/null
+++ b/dev-python/smartypants/smartypants-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+MY_PN="${PN}.py"
+MY_P="${MY_PN}-${PV}"
+
+inherit distutils-r1
+
+DESCRIPTION="ASCII quote-dot-dash to HTML entity converter"
+HOMEPAGE="https://pypi.python.org/pypi/smartypants/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/leohemsted/smartypants.py.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/leohemsted/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+distutils_enable_sphinx docs