summaryrefslogtreecommitdiff
path: root/dev-python/slixmpp/slixmpp-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-python/slixmpp/slixmpp-9999.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-python/slixmpp/slixmpp-9999.ebuild')
-rw-r--r--dev-python/slixmpp/slixmpp-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/slixmpp/slixmpp-9999.ebuild b/dev-python/slixmpp/slixmpp-9999.ebuild
new file mode 100644
index 000000000000..be8cfcfecb51
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://dev.louiz.org/projects/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-dns/libidn
+ test? ( $RDEPEND )
+"
+
+python_test() {
+ esetup.py test
+}