summaryrefslogtreecommitdiff
path: root/dev-python/slixmpp/slixmpp-1.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /dev-python/slixmpp/slixmpp-1.7.1.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'dev-python/slixmpp/slixmpp-1.7.1.ebuild')
-rw-r--r--dev-python/slixmpp/slixmpp-1.7.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/slixmpp/slixmpp-1.7.1.ebuild b/dev-python/slixmpp/slixmpp-1.7.1.ebuild
index 19974e840958..e37f059d7d37 100644
--- a/dev-python/slixmpp/slixmpp-1.7.1.ebuild
+++ b/dev-python/slixmpp/slixmpp-1.7.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -31,8 +31,8 @@ RDEPEND="
${DEPEND}
"
-distutils_enable_tests unittest
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
-python_test() {
- "${EPYTHON}" ./run_tests.py || die "Tests failed with ${EPYTHON}"
-}
+distutils_enable_tests unittest