summaryrefslogtreecommitdiff
path: root/dev-python/slimit/slimit-0.8.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
commit6c30cc2d5bd48ddbdbe8d75544899cd5dbfcaba4 (patch)
tree6ef7f6e1d48141a5da904d788b906da5bba4b697 /dev-python/slimit/slimit-0.8.1-r1.ebuild
parent62f82c107c3904ac6917ece47301d2999c7dd90e (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/slimit/slimit-0.8.1-r1.ebuild')
-rw-r--r--dev-python/slimit/slimit-0.8.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/slimit/slimit-0.8.1-r1.ebuild b/dev-python/slimit/slimit-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..b4561d3f8de2
--- /dev/null
+++ b/dev-python/slimit/slimit-0.8.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy{,3} python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A JavaScript minifier written in Python"
+HOMEPAGE="https://slimit.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/rspivak/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/ply:=[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}/${P}-fix-python3.patch" )
+
+python_compile() {
+ distutils-r1_python_compile
+
+ rm "${BUILD_DIR}"/lib/slimit/*tab.py || die
+
+ # Regenerate yacctab.py and lextab.py files to avoid warnings whenever
+ # the module is imported. See https://github.com/rspivak/slimit/issues/97
+ # for details
+ "${EPYTHON}" -B -c 'import slimit;slimit.minify("")' || die
+}
+
+python_test() {
+ esetup.py pytest --addopts "${BUILD_DIR}" || die "Testing failed with ${EPYTHON}"
+}