summaryrefslogtreecommitdiff
path: root/dev-python/six
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-python/six
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/Manifest2
-rw-r--r--dev-python/six/six-1.15.0-r1.ebuild (renamed from dev-python/six/six-1.15.0.ebuild)18
2 files changed, 3 insertions, 17 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
index 0a9e58e4957e..7fc7c8d5edab 100644
--- a/dev-python/six/Manifest
+++ b/dev-python/six/Manifest
@@ -1,3 +1,3 @@
DIST six-1.15.0.tar.gz 33917 BLAKE2B 57e852b6c35dd19e256814c0371cfbc26141b0f25a31f79a1cbd1b0cdd7d3cacf1236b96f5452f968cc426e6dff4d1ad70a9f2432bc361ba3c8c17fd40fe7582 SHA512 eb840ac17f433f1fc4af56de75cfbfe0b54e6a737bb23c453bf09a4a13d768d153e46064880dc763f4c5cc2785b78ea6d3d3b4a41fed181cb9064837e3f699a9
-EBUILD six-1.15.0.ebuild 958 BLAKE2B e3d15c5805d938af552b1da3f5bdf5ff2d1b31fba3aee7523e8230183d1d85766bd7520c3288b926f00795b0bec8faedd6b567bb80600654a765c8c2f24906bc SHA512 8aeefa7cd592b50d11267c3b8c5aba5b805d599adb02cb116950624f14f265b296a5553939edca44792b6f2b292eadfec8885f4adb0c8a48454497b8dff43125
+EBUILD six-1.15.0-r1.ebuild 677 BLAKE2B 3b30f1b55efed78b9390c14e5243a7c7c969b012c36238cb3c469925008c64aff214e042cd204500b66ebe7430a59443438d1215d16f8124c94d7d388d557e8a SHA512 0795825dd331137a0016332b6da550eafdae383a790ce9d38b0a1defb1a5461315dd8ca755108a938b49262e7d7863e95b4696e8adc4c29785b55429d68ffcf1
MISC metadata.xml 396 BLAKE2B 4b08f7faa6e73dee9d4f39caebc0eef9901f408c1cdfe5d883b350af406de2731e654c2a1c266daf07299451f57b8a717214ca1716463f7f43b376a51b4f6c2c SHA512 03881122a5eae7539c27d078eaf69f34e121f3a8a43c7e0ca9470c0ec6863ea268b5facc64e0ab100cc6b8c00473f784042047f077ceaa7f13d70d71dce03391
diff --git a/dev-python/six/six-1.15.0.ebuild b/dev-python/six/six-1.15.0-r1.ebuild
index 2ad1ac731cac..2206dac04197 100644
--- a/dev-python/six/six-1.15.0.ebuild
+++ b/dev-python/six/six-1.15.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
inherit distutils-r1
@@ -14,20 +14,6 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]' -3)
- )"
distutils_enable_sphinx documentation --no-autodoc
-
-python_test() {
- if ! python_is_python3; then
- einfo "Tests are skipped on Python 2 to unblock deps"
- return
- fi
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}
+distutils_enable_tests pytest