summaryrefslogtreecommitdiff
path: root/dev-python/six
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
commitc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (patch)
tree3ee550255947da075650f1a551dcc278f9a1b7f8 /dev-python/six
parenta978c074e4272bb901fbe4a10de0a7b2af574f17 (diff)
gentoo resync : 07.05.2021
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/Manifest4
-rw-r--r--dev-python/six/six-1.15.0-r1.ebuild11
-rw-r--r--dev-python/six/six-1.16.0.ebuild28
3 files changed, 41 insertions, 2 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
index d56ae9d5c56b..b81b795be282 100644
--- a/dev-python/six/Manifest
+++ b/dev-python/six/Manifest
@@ -1,3 +1,5 @@
DIST six-1.15.0.tar.gz 33917 BLAKE2B 57e852b6c35dd19e256814c0371cfbc26141b0f25a31f79a1cbd1b0cdd7d3cacf1236b96f5452f968cc426e6dff4d1ad70a9f2432bc361ba3c8c17fd40fe7582 SHA512 eb840ac17f433f1fc4af56de75cfbfe0b54e6a737bb23c453bf09a4a13d768d153e46064880dc763f4c5cc2785b78ea6d3d3b4a41fed181cb9064837e3f699a9
-EBUILD six-1.15.0-r1.ebuild 665 BLAKE2B accbe2ed89713d704e78c3eb7b887e2e92d21332dcbeba4bdb019ac7f8312d3e48e07d536fe9d8cfca493dd8f6b715a49a91c1894ee0b55345318ca2131cbe3c SHA512 1d71f0749752253db66fcbd09e5c0ea7dcd87b6d096bc379c5f9303d11ff4f63b0e933805d2b814a8fa16d2f0ba32f02039f5815569b130a883027f188eb5414
+DIST six-1.16.0.tar.gz 34041 BLAKE2B 764f8da9a0d89e95af002c79c2b19e852fdec9a6819655c57be019b48bd65a5f7909473e71887e6080073f381f983c077487591d4e44297542cf6b9a29ba42b8 SHA512 076fe31c8f03b0b52ff44346759c7dc8317da0972403b84dfe5898179f55acdba6c78827e0f8a53ff20afe8b76432c6fe0d655a75c24259d9acbaa4d9e8015c0
+EBUILD six-1.15.0-r1.ebuild 830 BLAKE2B 1796d67b0193d7e8be88113297ea741a9719db600a8df6f2e1e047074dba7dc09cc003bff171173d33f2c2c9672062f1eeb8a488a64cf3f76b36e40da5c6057f SHA512 85f3222d2cd6c384f2abfcb86912df7ab3ba394b38e0ac2092e83b0980232f694db8feee48a05770590140a5b0f48fde51b0764343c863405fcd09032f91f5cd
+EBUILD six-1.16.0.ebuild 838 BLAKE2B c31d2baf2b8d79f70a6945bb47bd4612ee966af8af4c5cd83428613efc3dca11f3e800a4d60f89a18da556d9daae4917be7d083b538d33f6aa163732ce92de34 SHA512 75e4a74227dfc79ac72c9c03d10534a49bd8953730b271ed006278392c3ac913cfe1de9a606bb2bebe457a574ed9b2ff8c0b909de75cfa73bbff3ac53f81c70a
MISC metadata.xml 396 BLAKE2B 4b08f7faa6e73dee9d4f39caebc0eef9901f408c1cdfe5d883b350af406de2731e654c2a1c266daf07299451f57b8a717214ca1716463f7f43b376a51b4f6c2c SHA512 03881122a5eae7539c27d078eaf69f34e121f3a8a43c7e0ca9470c0ec6863ea268b5facc64e0ab100cc6b8c00473f784042047f077ceaa7f13d70d71dce03391
diff --git a/dev-python/six/six-1.15.0-r1.ebuild b/dev-python/six/six-1.15.0-r1.ebuild
index 7c34eb62693a..830bec098c8c 100644
--- a/dev-python/six/six-1.15.0-r1.ebuild
+++ b/dev-python/six/six-1.15.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -17,3 +17,12 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 s
distutils_enable_sphinx documentation --no-autodoc
distutils_enable_tests pytest
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ 'test_six.py::test_move_items[dbm_ndbm]'
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}
diff --git a/dev-python/six/six-1.16.0.ebuild b/dev-python/six/six-1.16.0.ebuild
new file mode 100644
index 000000000000..7c6266910ab4
--- /dev/null
+++ b/dev-python/six/six-1.16.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_sphinx documentation --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ 'test_six.py::test_move_items[dbm_ndbm]'
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}