summaryrefslogtreecommitdiff
path: root/dev-python/six
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-09 00:01:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-09 00:01:03 +0100
commita0ce545d52f231499bf9f3644493113d8af58ec9 (patch)
tree4d67c09eed0c2ae28d1317f72d7f7b08b4f6aeea /dev-python/six
parent5181ced3f3566a9610b85922b083c8f84f20d78f (diff)
gentoo auto-resync : 09:05:2024 - 00:01:03
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/Manifest2
-rw-r--r--dev-python/six/six-1.16.0-r1.ebuild22
2 files changed, 17 insertions, 7 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
index b85cb3034b71..45d010c92ab8 100644
--- a/dev-python/six/Manifest
+++ b/dev-python/six/Manifest
@@ -1,3 +1,3 @@
DIST six-1.16.0.tar.gz 34041 BLAKE2B 764f8da9a0d89e95af002c79c2b19e852fdec9a6819655c57be019b48bd65a5f7909473e71887e6080073f381f983c077487591d4e44297542cf6b9a29ba42b8 SHA512 076fe31c8f03b0b52ff44346759c7dc8317da0972403b84dfe5898179f55acdba6c78827e0f8a53ff20afe8b76432c6fe0d655a75c24259d9acbaa4d9e8015c0
-EBUILD six-1.16.0-r1.ebuild 771 BLAKE2B b0df1c73cd382d370693bfb9fd385a70f241c60ab1e7953198d96f60812bdd7dccd5746fe444403c3a462c11e454246b69882d18c2f9607cc2d33f68c0e46352 SHA512 afa2b9a38b57d83ee1ee93af70a18fad2e7a5a4ec6b9346d27834390facdb3982517d6ab0b8acc5f014faf401328b24deb338a7df41f20df67c169253af97170
+EBUILD six-1.16.0-r1.ebuild 928 BLAKE2B 5262c9c3055bdb1d29c87a4cf84d368c743052439ec722535e944470f8af90c67f58e5367d24dccac0b2d05833d0e5a040d9a90f956f827127702d3cddce9408 SHA512 34ff2af78055efed757abd3f933ef19a1f8d293a7dd8fe969d6502bb3935225b087a8980caf423d8d916947e93483e96c35969b98f0cd708709b671921fbe4bc
MISC metadata.xml 397 BLAKE2B ec6bbdf426ea83004d6c5eae83e650c6d601d639a51a08e58e9bc7d187877bbec9cb89f05f7b44ad521a2cc4f82269503cbd5f882c8e67d96a9018500803f931 SHA512 13d061df717192e9de816f03d7386218d8a760665d2d6ff2187da9152d0a7d7085df96cecbf47d76f9099b0eea8640506fce924d52e1f16300a6bcb06a2406b8
diff --git a/dev-python/six/six-1.16.0-r1.ebuild b/dev-python/six/six-1.16.0-r1.ebuild
index df1788703008..9850b41681e3 100644
--- a/dev-python/six/six-1.16.0-r1.ebuild
+++ b/dev-python/six/six-1.16.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -23,9 +23,19 @@ distutils_enable_tests pytest
python_test() {
local EPYTEST_DESELECT=()
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- 'test_six.py::test_move_items[dbm_ndbm]'
- )
-
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ 'test_six.py::test_move_items[dbm_ndbm]'
+ )
+ ;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ 'test_six.py::test_move_items[tkinter_tix]'
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}