summaryrefslogtreecommitdiff
path: root/dev-python/six
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-15 04:04:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-15 04:04:09 +0100
commit45392c898b8ba163e95028bd98896e77f0c73806 (patch)
treebf6b64dd472acc2960a5c24b26dd0ac036b47d0d /dev-python/six
parent2916cf6049cf9d3092021e247d56c580df6029a7 (diff)
gentoo auto-resync : 15:10:2024 - 04:04:09
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/Manifest2
-rw-r--r--dev-python/six/six-1.16.0-r1.ebuild16
2 files changed, 9 insertions, 9 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
index a75f8670aafb..093cbf9450d0 100644
--- a/dev-python/six/Manifest
+++ b/dev-python/six/Manifest
@@ -1,3 +1,3 @@
DIST six-1.16.0.tar.gz 34041 BLAKE2B 764f8da9a0d89e95af002c79c2b19e852fdec9a6819655c57be019b48bd65a5f7909473e71887e6080073f381f983c077487591d4e44297542cf6b9a29ba42b8 SHA512 076fe31c8f03b0b52ff44346759c7dc8317da0972403b84dfe5898179f55acdba6c78827e0f8a53ff20afe8b76432c6fe0d655a75c24259d9acbaa4d9e8015c0
-EBUILD six-1.16.0-r1.ebuild 922 BLAKE2B d3fbf846f86aeeb3d3b733c5b1c1191396062f4fe26a007147510bc61579b94a7bd9d75dcd9d5582eae66140d44e1cfe6f136f81621f475269a8ae58f2497245 SHA512 d0e152d4e6faf190aa0884d1c5a42dbc875c341babb90bd0e67f63d42d25d32ced0a7e027b74b3d204782ffb3e6da4ee2f8646b2c74c0cbab0baa2342339b77e
+EBUILD six-1.16.0-r1.ebuild 979 BLAKE2B f5b7cf5daef14a061b20821fbced7bedad3d3ea747da1267dd20606fbcc4b8d46f2492abd57493df262f55461ef78c3af09acb3e0f1d4d329f0780f43799f5ac SHA512 5603c043dae9a3b72a071ace344ef87defe92e646095312a8217d150e03cb15b9259cadcdda9c57ce92c2010b9bdc5c4efd5e466b1490ea31ce4e9915af8073e
MISC metadata.xml 397 BLAKE2B ec6bbdf426ea83004d6c5eae83e650c6d601d639a51a08e58e9bc7d187877bbec9cb89f05f7b44ad521a2cc4f82269503cbd5f882c8e67d96a9018500803f931 SHA512 13d061df717192e9de816f03d7386218d8a760665d2d6ff2187da9152d0a7d7085df96cecbf47d76f9099b0eea8640506fce924d52e1f16300a6bcb06a2406b8
diff --git a/dev-python/six/six-1.16.0-r1.ebuild b/dev-python/six/six-1.16.0-r1.ebuild
index 4554e1d0fd4a..d7f93534815a 100644
--- a/dev-python/six/six-1.16.0-r1.ebuild
+++ b/dev-python/six/six-1.16.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} python3_13t pypy3 )
inherit distutils-r1 pypi
@@ -22,14 +22,14 @@ distutils_enable_sphinx documentation --no-autodoc
distutils_enable_tests pytest
python_test() {
- local EPYTEST_DESELECT=()
+ local EPYTEST_DESELECT=(
+ # requires USE=gdb on CPython, no point in forcing the dep
+ # also missing on PyPy
+ 'test_six.py::test_move_items[dbm_ndbm]'
+ )
+
case ${EPYTHON} in
- pypy3)
- EPYTEST_DESELECT+=(
- 'test_six.py::test_move_items[dbm_ndbm]'
- )
- ;;
- python3.13)
+ python3.13*)
EPYTEST_DESELECT+=(
'test_six.py::test_move_items[tkinter_tix]'
)