summaryrefslogtreecommitdiff
path: root/dev-python/sip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-24 22:45:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-24 22:45:43 +0000
commit3f6b99c9f74a0a7bfa2e18f0a7bc7057739cc00b (patch)
treee56393aac5dcc184833b4e155d45468003757d48 /dev-python/sip
parentb0fd0bc5c186e99078ed8d07146e8c14f1089639 (diff)
gentoo auto-resync : 24:01:2024 - 22:45:43
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest2
-rw-r--r--dev-python/sip/sip-6.8.2.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index a8d773eeafef..489d2a1b692d 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,3 +1,5 @@
DIST sip-6.8.1.tar.gz 986219 BLAKE2B c9055b1aff3314661bfa2daa4fab465b57e811976aeb76fc2dafcb684b4ff2274c4eed88952ccfa904dd0e04a73f8f1eb6b969409146cbb80d3f1a2f58af9a99 SHA512 315243ec94fa66165ea458b64ab11d5b682f17723148e4dbe844dc31d6d7b024458a58c68bf2643f0930a31f28821b85a99fa1b02431a9a2e1c0d8ddd1df3342
+DIST sip-6.8.2.tar.gz 987521 BLAKE2B 318058b2c7f03cb5cdbd56628233eedf26edd10a61e7ef505d463d01542cceb19e2eb15ca82eb6679c4ae646ecbbbca636ef105a2e73c368fdc69a621a28a4c2 SHA512 7edc3d10256d6622179cb4d207227935786399de52adcffc7fa9dd9d05b32488823642ed128e30195c3e71e470c48ae49e2c2225b76116e849496d2197571d4f
EBUILD sip-6.8.1.ebuild 653 BLAKE2B 263a00503853ec3e615e5bd66d0b2a029749cd4960132c36abd7a5c1701adc2f38959727c09a8504b2c2f76379b756ac7209ef28d74a5e9ac414d99c1bf83dff SHA512 e02377d502a7d1eae26b2d55ef0f88cee782e252ec67f17caa23d4342da412430261d60198763c5dd795d19155dbfe02795f6e2b6f8a9fe7bd0f20137a82df03
+EBUILD sip-6.8.2.ebuild 659 BLAKE2B c84e2d86fcb9e252525aba3581cf2d9f6047dd5a7ae04a94217392d7ba56e9aa1fb4f4fc3dbfbaa98e45f28cb57bbb2f93d8d49e079bfca4c3b91b928d200d13 SHA512 65975a45f308059915278ded25a4b71dd4773bbfaf31951ab51bf9774c5e0f576ff907f0f964e92d11306afea2c78596ff4f9d0479afef04f00b366212052413
MISC metadata.xml 663 BLAKE2B df97b2104f63a42ffb6406bd577cefce51adc7e924aea96490e2cf60fad6975d3a9a3c3000f44dc49d193123559bc78efe3221c649642ff3f1d0a195b7102338 SHA512 7db390ee64b7e0d2b5d2dc85f3ba74714894978d85f9ac3b4cf4217827024b2129ca6f9f2e7c1d54301866690b926808b28d80b376247b9092c42198c7bff32b
diff --git a/dev-python/sip/sip-6.8.2.ebuild b/dev-python/sip/sip-6.8.2.ebuild
new file mode 100644
index 000000000000..a1fec821017b
--- /dev/null
+++ b/dev-python/sip/sip-6.8.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings generator for C/C++ libraries"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10)
+"
+
+distutils_enable_sphinx doc --no-autodoc