summaryrefslogtreecommitdiff
path: root/dev-python/singledispatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/singledispatch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/singledispatch')
-rw-r--r--dev-python/singledispatch/Manifest3
-rw-r--r--dev-python/singledispatch/metadata.xml15
-rw-r--r--dev-python/singledispatch/singledispatch-3.4.0.3.ebuild20
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/singledispatch/Manifest b/dev-python/singledispatch/Manifest
new file mode 100644
index 000000000000..bc43b6e1d05b
--- /dev/null
+++ b/dev-python/singledispatch/Manifest
@@ -0,0 +1,3 @@
+DIST singledispatch-3.4.0.3.tar.gz 9529 BLAKE2B 51e948c1a60adac7db3b97931becad4c699277b7c6af2e211e160fd6ec8fdf0501a3a2b40780b9bf7a2a5c62d08d905c7058c5a771018f9ec78a60688e3b03b5 SHA512 ba065d36092ddee6527be3d7cb777c51c0949855bf6dd0ffb7c25acaedaa35d36fe6dc096587acddcd1e9e54c6ac5f92c196b11f9ee1270cc0c1cf2f410446cf
+EBUILD singledispatch-3.4.0.3.ebuild 648 BLAKE2B 22354d7c5a54b57dd657eebe8d2213f4909d3f58afe25b8390b7ebde792996d5f3d4907cd742dafe2f07f05925ca7dabd23b0babe1131d24487aca12ae37a6f3 SHA512 0c6dc90780347f87fc5f35cff1f55bfad907ade445b8b0a6289115b0141e1ed6ad4caee99ea6e2da31bf3e13d7b2a84095c303eb74c8ac0669160e145bee7eaa
+MISC metadata.xml 463 BLAKE2B b72d957aeb11979138c6d0bb9b7181de4bc7a899f7fa5ea5f91c58b447a0643b6c94263af24d1fea434752a0fd1178f1d388ea5d4e0e1f043ddd9b93b4c60947 SHA512 5375100b85310a816ee67ed7ccd23b7e17e3bc35e483166673c7cbd3a49b82166e9a4f4df0effb7b5f0bf1529fec26f3f8fcc692677ae7849d2d7501cc326950
diff --git a/dev-python/singledispatch/metadata.xml b/dev-python/singledispatch/metadata.xml
new file mode 100644
index 000000000000..59b6525d4d96
--- /dev/null
+++ b/dev-python/singledispatch/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>timo@rothenpieler.org</email>
+ <name>Timo Rothenpieler</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">singledispatch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/singledispatch/singledispatch-3.4.0.3.ebuild b/dev-python/singledispatch/singledispatch-3.4.0.3.ebuild
new file mode 100644
index 000000000000..176fc1e7e058
--- /dev/null
+++ b/dev-python/singledispatch/singledispatch-3.4.0.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to bring functools.singledispatch from Python 3.4 to Python 2.6-3.3"
+HOMEPAGE="https://docs.python.org/3/library/functools.html#functools.singledispatch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PF}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"