summaryrefslogtreecommitdiff
path: root/dev-python/simplejson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 18:07:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 18:07:08 +0000
commitd46d0aa37cf8b6304aea3c3f2a1be8cca389e989 (patch)
treedbfd9db95941a47b8ecb038ae6792beba39799af /dev-python/simplejson
parent4551b41523452c0d743a71cca34e4dca2ca7538c (diff)
gentoo auto-resync : 04:01:2023 - 18:07:08
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest2
-rw-r--r--dev-python/simplejson/simplejson-3.18.1.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index 25f658e3d57a..397eee8412e1 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,3 +1,5 @@
DIST simplejson-3.18.0.tar.gz 83533 BLAKE2B 83c6f7f3734507f5a96b51d52dd39b0bd8ff772d51ce1f12ff2ee68f83747f519f418f78247727af7c408da4e7818d1b0d1f7b54b7780e3bc427add1eeaebb06 SHA512 952177fc707e5b1fb6450093876f9a7af1026271cb792bb8dc0418b83906ae32e7f2251b96f531101197d0b3204a97124bff02f7abc4cf700da4edf1320b6b08
+DIST simplejson-3.18.1.tar.gz 83603 BLAKE2B 5f51d06238210b0bdd3dbb2338979023324e1056c2278f7eef7b929cc0bf9f9178d032829a3ce49c0b630f3367268d68753f250968962159e9a9aafcd3105d20 SHA512 3a18d02f42624e27c536582cf9b6ceb8559d54dd97224294a6f6ee8173ee37c0cc9cd21bad777c29ab432ac41b1495fca9d45da300b5040c175980d236d3b9d6
EBUILD simplejson-3.18.0.ebuild 673 BLAKE2B 6900d97f50ed7c08a00ecafbe5698284d875c62c33d38d55dfe08dfc1fc817720adc1ae45f213670e12e3a9d0e41f50072b3c9f5dda948f0a7d194d33dbcb472 SHA512 2e817ebbcd60bb421b64efdd302880615c598b227c8caa2eb9057106a5ca04e9abd4ea5c073bcda421402c3529f553bd388fe96ae84c21f1b2fa2165455a1954
+EBUILD simplejson-3.18.1.ebuild 681 BLAKE2B 69d3f308279a33f21de5b4720013694996dd48ba3cee1eb840b2d03e29fecac2a77fecfc35198f96dee0230ee0c25db340a8ce7bbf83fca3ee95f269d5e82aa2 SHA512 265ea7857eda89070ce461082a20dbec0179d186e6950091e8e3f643cbfb4ffc42c43afed729887ae8a4e65d3a96c30f7de0a233811e04f6191ff91ba90d6e6d
MISC metadata.xml 375 BLAKE2B 2c3a0f98ee3f6c9ba41edf3e8e4d6536ac518a59234e6c602d46cbfcb8a5c760c71997b3c169dd2c0b3f9c5dcbea1cb36967e4d050933bd5e31d6f609a835e83 SHA512 6ad418641e64295566aa5418b9bead66e7ea84e0ca7aa454bfedf613cde7ed4d1cd17dff962963c3dda62ad9050e6348f9f53da21ba25b53cdeba2d91b8c551d
diff --git a/dev-python/simplejson/simplejson-3.18.1.ebuild b/dev-python/simplejson/simplejson-3.18.1.ebuild
new file mode 100644
index 000000000000..b36a545149a5
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.18.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="
+ https://github.com/simplejson/simplejson/
+ https://pypi.org/project/simplejson/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest