summaryrefslogtreecommitdiff
path: root/dev-python/simplejson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-15 12:21:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-15 12:21:13 +0000
commitcf5d856691cbc347f5816a181e5bf767792afa55 (patch)
tree239945541c80dfa78133d5e9ab5c52c25a222b09 /dev-python/simplejson
parentbb007f0b04c719fd2b846d177c3c4739fdb7c318 (diff)
gentoo auto-resync : 15:03:2023 - 12:21:13
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest2
-rw-r--r--dev-python/simplejson/simplejson-3.18.4.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index d7bf0e56f2c7..c4a15f9dd4c9 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,3 +1,5 @@
DIST simplejson-3.18.3.gh.tar.gz 81540 BLAKE2B bf6a162499b28a362638e19735f668571f88943ae396fb7f813d51ab0684caa8cb996a35deaf1d68adee2a812d685058e9e80d6f6e66604bbb7c704051b0b37f SHA512 54223e08775ab6277722342084bf56684588dd9dda574428cb73b791d37d0b74decef6082268c0389cc4586a534a19e62ec5738fa9ffffaee63f68e27fb465c8
+DIST simplejson-3.18.4.tar.gz 83721 BLAKE2B fb9ea04402ba740a445751ff2be2f5f5c826e20f38289dcf9aa9c8abbaba4b59bf906c3378317818c77bcfa6ccc3fe76608651eac660683eeac61f5750099e3d SHA512 6335389eb620c96d5c537cd335e20d4f112b86c0c463ceed4d8fa36c27bab8b00386b7995e40070bda5eed1fe5883a462579c7d09bdbc828c39537282669d0e4
EBUILD simplejson-3.18.3.ebuild 956 BLAKE2B 91409a554c70ddbddf6bf6c22a19a406344a62b6cf99b1befdc45c5a200dd78dba22d3f21372cc70c58521577df9f6221dac29e5955ed5428d868901db310650 SHA512 0f8207f9a27de53edc93e82f4d27e075496c166b8985c30c12994469844f0166c7880c971cbbe1a22326eaaa689d92d6e414abd34a616d5baf4a30ef5f287d9b
+EBUILD simplejson-3.18.4.ebuild 873 BLAKE2B 1bb6e18767e5f232ad972a996a4870a4a3f791ccd98a4a468b023bcdb5a85af598429a408016145a122fc015bc2e6947bb7289b6326e2f277d75a691ed7f904f SHA512 b940fc6f65f54e93c17ceef010aec99347691726e8ec58718e8f9fc8e27dc523511b77a3d19f68eab7a733edd7ec6ae6392b886a5007f51173aa0f842ad1d1d9
MISC metadata.xml 522 BLAKE2B b8b8fdade498ef65f4d5d6e30bc9f0708390f3d064a332d04f0b33346224c59252ef3d512a5a7187c637348201829ccc83254cd898e8df06dff314e857debb58 SHA512 1a1b53900ef62d4d40977504378dce3ce15f1c56ae5a73263127f5919674b1f9b13964128550e0c0e274d4bf50f2c2b438626e3ba1a5f8436071e1eb2f4c30af
diff --git a/dev-python/simplejson/simplejson-3.18.4.ebuild b/dev-python/simplejson/simplejson-3.18.4.ebuild
new file mode 100644
index 000000000000..8afcfa37c4ea
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.18.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="
+ https://github.com/simplejson/simplejson/
+ https://pypi.org/project/simplejson/
+"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="+native-extensions"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest
+
+src_configure() {
+ export DISABLE_SPEEDUPS=$(usex native-extensions 0 1)
+ use native-extensions && export REQUIRE_SPEEDUPS=1
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}