summaryrefslogtreecommitdiff
path: root/dev-python/simplejson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-06 16:19:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-06 16:19:28 +0000
commit9afce155a599e5f4518f3c7913b6424ac13be12e (patch)
tree60420eafdcf940c0e4555d9aa8e4e9017a646344 /dev-python/simplejson
parenteb7aa327b218d640c8bda63ba0fd1ace2bd2d17b (diff)
gentoo auto-resync : 06:11:2023 - 16:19:27
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest2
-rw-r--r--dev-python/simplejson/simplejson-3.19.1.ebuild37
2 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index fee5159c8bc3..6188afb00823 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,5 +1,3 @@
-DIST simplejson-3.19.1.tar.gz 85207 BLAKE2B 4c3d1d5de4292404e44977777332fe57327ece1afcd9890b605d52a248764612da351b7c5afb36d4e1cdcb530f07b99b8d971124899b86e4b2f4005a66afcbb5 SHA512 a2239a932f43abe59da84fc3ba95eeaa6a720c929da79d8f4447603b8c770403c9cba0f008a66c20c5c8aa3255891b687336eef1db071171a2c8435563bbb1bd
DIST simplejson-3.19.2.tar.gz 85311 BLAKE2B eecbe77c9612468a0ce52b165be9b4fc4b3d8bcca99621a2723c50fc0c89cdce981421ba71b85535f1c66b48b7178da37f117f9dec8a66cb6f3fe83e3d2d033e SHA512 d92bf617e27b66d93a5d176d38c0c6ae2777728d1e43fdb8054cc9c2b50e3f340079c82dd3ec1af36c8d6380833d16e8eecdc8dd950bba953c195256b44b46c5
-EBUILD simplejson-3.19.1.ebuild 1001 BLAKE2B 28ed0eddaa5214cce1b91d67f9660aed2eef9d035b19d03daec866d1ddde9e21c4842a19bd58109e746b3baf288eb8591170050f8614beb9aa11d21d0fea5671 SHA512 db0952d96fd7b61b12c46ef28527b4418ee83875696d1ada1fbbb67544a0eaf2cedbb711a407b58520744b6049daeefe3647222008abfec33b7e216bd5677ba0
EBUILD simplejson-3.19.2.ebuild 1001 BLAKE2B 28ed0eddaa5214cce1b91d67f9660aed2eef9d035b19d03daec866d1ddde9e21c4842a19bd58109e746b3baf288eb8591170050f8614beb9aa11d21d0fea5671 SHA512 db0952d96fd7b61b12c46ef28527b4418ee83875696d1ada1fbbb67544a0eaf2cedbb711a407b58520744b6049daeefe3647222008abfec33b7e216bd5677ba0
MISC metadata.xml 522 BLAKE2B b8b8fdade498ef65f4d5d6e30bc9f0708390f3d064a332d04f0b33346224c59252ef3d512a5a7187c637348201829ccc83254cd898e8df06dff314e857debb58 SHA512 1a1b53900ef62d4d40977504378dce3ce15f1c56ae5a73263127f5919674b1f9b13964128550e0c0e274d4bf50f2c2b438626e3ba1a5f8436071e1eb2f4c30af
diff --git a/dev-python/simplejson/simplejson-3.19.1.ebuild b/dev-python/simplejson/simplejson-3.19.1.ebuild
deleted file mode 100644
index a014c1d7ed9b..000000000000
--- a/dev-python/simplejson/simplejson-3.19.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE="
- https://github.com/simplejson/simplejson/
- https://pypi.org/project/simplejson/
-"
-
-LICENSE="|| ( MIT AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="+native-extensions"
-
-DOCS=( README.rst CHANGES.txt )
-
-distutils_enable_tests unittest
-
-src_configure() {
- # native-extensions are always disabled on PyPy
- # https://github.com/simplejson/simplejson/blob/master/setup.py#L121
- export DISABLE_SPEEDUPS=$(usex native-extensions 0 1)
- use native-extensions && export REQUIRE_SPEEDUPS=1
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
- eunittest
-}