summaryrefslogtreecommitdiff
path: root/dev-python/simplejson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-15 12:52:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-15 12:52:47 +0000
commit8b256c06858dd62dc5a70f801c732e9ab8226123 (patch)
treed30e45ce0630a0f829dc01cd744061ba3f500811 /dev-python/simplejson
parent9f7759b3b1be5a3bc7794010a8ebf9334f017d2f (diff)
gentoo auto-resync : 15:11:2022 - 12:52:47
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest2
-rw-r--r--dev-python/simplejson/simplejson-3.18.0.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index d88e84e1518d..84c283d28d39 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,3 +1,5 @@
DIST simplejson-3.17.6.tar.gz 83134 BLAKE2B 5aa9275673a0c8feab2a86f1bc85864791a847a7eda77ea6f3e4f8d8677ff88d2277ff659285d183d2d439c58e78b25846badb3a2fddbc959d40eb23273dfa2b SHA512 4a25032fcc78025d82db571716deef8769f036a330560f92e14563687db4a42dbe60866b8afb57baf24104ef94fcbe938cdbddfc169542664957eef2d00d04e3
+DIST simplejson-3.18.0.tar.gz 83533 BLAKE2B 83c6f7f3734507f5a96b51d52dd39b0bd8ff772d51ce1f12ff2ee68f83747f519f418f78247727af7c408da4e7818d1b0d1f7b54b7780e3bc427add1eeaebb06 SHA512 952177fc707e5b1fb6450093876f9a7af1026271cb792bb8dc0418b83906ae32e7f2251b96f531101197d0b3204a97124bff02f7abc4cf700da4edf1320b6b08
EBUILD simplejson-3.17.6.ebuild 673 BLAKE2B 6900d97f50ed7c08a00ecafbe5698284d875c62c33d38d55dfe08dfc1fc817720adc1ae45f213670e12e3a9d0e41f50072b3c9f5dda948f0a7d194d33dbcb472 SHA512 2e817ebbcd60bb421b64efdd302880615c598b227c8caa2eb9057106a5ca04e9abd4ea5c073bcda421402c3529f553bd388fe96ae84c21f1b2fa2165455a1954
+EBUILD simplejson-3.18.0.ebuild 681 BLAKE2B 404388de6ac84f52a17a4d7d450c4f128e86aceda17b764894a260c84e9b1b58012f1659d95852dd75a35ac8ad9d669b05837d962c42ab80297bfe1f8838717e SHA512 73cd38632b70dfcd52e2f78733e58e3a1b63d140a3b8a7d94d5c839d16cab3527aa1225b1b7bd9ab16d46954e70d0200a55a97052d12d822bafa093d9cf8ad76
MISC metadata.xml 375 BLAKE2B 2c3a0f98ee3f6c9ba41edf3e8e4d6536ac518a59234e6c602d46cbfcb8a5c760c71997b3c169dd2c0b3f9c5dcbea1cb36967e4d050933bd5e31d6f609a835e83 SHA512 6ad418641e64295566aa5418b9bead66e7ea84e0ca7aa454bfedf613cde7ed4d1cd17dff962963c3dda62ad9050e6348f9f53da21ba25b53cdeba2d91b8c551d
diff --git a/dev-python/simplejson/simplejson-3.18.0.ebuild b/dev-python/simplejson/simplejson-3.18.0.ebuild
new file mode 100644
index 000000000000..84d4dee1f814
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.18.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="
+ https://github.com/simplejson/simplejson/
+ https://pypi.org/project/simplejson/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest