summaryrefslogtreecommitdiff
path: root/dev-python/simplejson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-06 17:57:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-06 17:57:58 +0100
commit8368c614e6a1232f34a14cd6495cf2f68933030d (patch)
treefb445ed1110e0361c9c25136c00c4fb948bb46c4 /dev-python/simplejson
parent2b03b0d9c5ca3890c219ebd24721133e766e9bb9 (diff)
gentoo auto-resync : 06:10:2023 - 17:57:58
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest2
-rw-r--r--dev-python/simplejson/simplejson-3.19.2.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index d40ad515a9fc..f0a84028cffd 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,3 +1,5 @@
DIST simplejson-3.19.1.tar.gz 85207 BLAKE2B 4c3d1d5de4292404e44977777332fe57327ece1afcd9890b605d52a248764612da351b7c5afb36d4e1cdcb530f07b99b8d971124899b86e4b2f4005a66afcbb5 SHA512 a2239a932f43abe59da84fc3ba95eeaa6a720c929da79d8f4447603b8c770403c9cba0f008a66c20c5c8aa3255891b687336eef1db071171a2c8435563bbb1bd
+DIST simplejson-3.19.2.tar.gz 85311 BLAKE2B eecbe77c9612468a0ce52b165be9b4fc4b3d8bcca99621a2723c50fc0c89cdce981421ba71b85535f1c66b48b7178da37f117f9dec8a66cb6f3fe83e3d2d033e SHA512 d92bf617e27b66d93a5d176d38c0c6ae2777728d1e43fdb8054cc9c2b50e3f340079c82dd3ec1af36c8d6380833d16e8eecdc8dd950bba953c195256b44b46c5
EBUILD simplejson-3.19.1.ebuild 1001 BLAKE2B 28ed0eddaa5214cce1b91d67f9660aed2eef9d035b19d03daec866d1ddde9e21c4842a19bd58109e746b3baf288eb8591170050f8614beb9aa11d21d0fea5671 SHA512 db0952d96fd7b61b12c46ef28527b4418ee83875696d1ada1fbbb67544a0eaf2cedbb711a407b58520744b6049daeefe3647222008abfec33b7e216bd5677ba0
+EBUILD simplejson-3.19.2.ebuild 1009 BLAKE2B c1778ad148cc8446f2676bb71d5ac6fb647f669e01cb3a78e5849bc88a2d5d280053804055bd412002da0cbe34d6c5c5db0a4efb1299db1641b1e35484f1c991 SHA512 fa5e9cd39f60a2bccd8a269e4d8f843786710f64e255ff20af7368a78cc718fc48d868524e473333063f32a49917aec7441b65ae1717788b068d2127ec08fab3
MISC metadata.xml 522 BLAKE2B b8b8fdade498ef65f4d5d6e30bc9f0708390f3d064a332d04f0b33346224c59252ef3d512a5a7187c637348201829ccc83254cd898e8df06dff314e857debb58 SHA512 1a1b53900ef62d4d40977504378dce3ce15f1c56ae5a73263127f5919674b1f9b13964128550e0c0e274d4bf50f2c2b438626e3ba1a5f8436071e1eb2f4c30af
diff --git a/dev-python/simplejson/simplejson-3.19.2.ebuild b/dev-python/simplejson/simplejson-3.19.2.ebuild
new file mode 100644
index 000000000000..d74a8e138ad7
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.19.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="
+ https://github.com/simplejson/simplejson/
+ https://pypi.org/project/simplejson/
+"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="+native-extensions"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest
+
+src_configure() {
+ # native-extensions are always disabled on PyPy
+ # https://github.com/simplejson/simplejson/blob/master/setup.py#L121
+ export DISABLE_SPEEDUPS=$(usex native-extensions 0 1)
+ use native-extensions && export REQUIRE_SPEEDUPS=1
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}