summaryrefslogtreecommitdiff
path: root/dev-python/simplejson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/simplejson
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest2
-rw-r--r--dev-python/simplejson/simplejson-3.17.2.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index d156dabea6b9..7d00d76fa8c9 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,3 +1,5 @@
DIST simplejson-3.17.0.tar.gz 83119 BLAKE2B 979dbcb5d50aeb55fd1c16daa398ef915ee1f23ca25a84870a3132c265202d1cd253090157cdea179cecc6603618df293a28adeadc795238ec3ccfceda88ea0a SHA512 383ee4fa3b2f378cd83152ba588ffbb620aa0e7cec80d3e3097edfb406a60e96afd6c5302a5b64adb710d3a52479c609873a2db7ab5756d7ca7a51412029e4c6
+DIST simplejson-3.17.2.tar.gz 83210 BLAKE2B 1b9f97a43bfe84f1ad506713d81483ebcd4006d1174558b7a27373f99d014e23ed72a9ec2b2006e64760c61e1e500a4f1ea4547104e7f4c71ba51003df0a5052 SHA512 003b2fbcb3f8e0849bdbd958c78f8b470081d97527bef82306db77940c6734a1cbf3b5dcb0984d2f9c9d14aa525e7865a08e70a10971f8841e138f7ad6476e4a
EBUILD simplejson-3.17.0.ebuild 774 BLAKE2B eaec307788c130d7e32ccc3760379e3712f1407b9180c1a087daab1327ac230caaeab92fe6a32df2d58219c11264b9c24317fc64b536a67e24ebf870fcb49a37 SHA512 69226587cf94ab5de79b4a1a0687ca2554b545807d9796ea23a9c82419b53d0d1ab6f36ef73a51936514a66c773f3655cc6c2b74eb690e1ac1a2763929d6eb03
+EBUILD simplejson-3.17.2.ebuild 776 BLAKE2B a938820f8aa423bc364b9ff1911c57aefdee6abf8bd2267ad54a1e09cdd83c81c77b5b3276e27bdcb2b7a21d5ef1fffdae08ae925f656ec8f3b61504196d51f2 SHA512 0a843a997904484049c71e683bf7effc17e1bc17311a48a7a99740a3aeca885bee92c45ad872fe82d9e7d4e65f63d747222c46bbcc4035ed3e27c880e6759be7
MISC metadata.xml 323 BLAKE2B c21be649394bb8a261a6169a710fd3862f1dd539505381a15f99611f323ea1e5fe4e6e54f1ed73d28bdddc2459812f13e40658ed99c09d0ba0f93f724b4bcfc9 SHA512 7db760ee80a6281bcc370303bafc40aea566465bf3264381336222c6f6002f573bfac205f2e42cca557c7b31855f082e1ed29ec9ab3b1125e455cf84bdaf54ec
diff --git a/dev-python/simplejson/simplejson-3.17.2.ebuild b/dev-python/simplejson/simplejson-3.17.2.ebuild
new file mode 100644
index 000000000000..262c80842335
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.17.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="https://github.com/simplejson/simplejson https://pypi.org/project/simplejson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ~ppc ~ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest
+
+python_compile() {
+ if ! python_is_python3; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
+}