summaryrefslogtreecommitdiff
path: root/dev-python/simplegeneric
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/simplegeneric
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/simplegeneric')
-rw-r--r--dev-python/simplegeneric/Manifest3
-rw-r--r--dev-python/simplegeneric/metadata.xml19
-rw-r--r--dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild26
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/simplegeneric/Manifest b/dev-python/simplegeneric/Manifest
new file mode 100644
index 000000000000..26c3ddbe1a5e
--- /dev/null
+++ b/dev-python/simplegeneric/Manifest
@@ -0,0 +1,3 @@
+DIST simplegeneric-0.8.1.zip 12663 BLAKE2B cc3d70f8f4f04209b7ce259c6caaccec001515a3da04736cb8baa5fe7e6091f4f85bdde0c5c4227a01bfe52739f51ab0116d8bfdc4bb58bd2188c3a54c5eac37 SHA512 74c25d4e04fe197058cb43fabe3702cc5901989dc0b0bcf7511369f4f3d90fd98e4225174db0680c8f39389914f82824bdbdaf4c302b53998fbabbf0dba393e4
+EBUILD simplegeneric-0.8.1-r1.ebuild 618 BLAKE2B c5959ba6bfe76a687d17048705f7c407babd3a0db7a03b8efcc825eac0f29c5171d5892c67fa0ea122c6580eb0825c80fae4b2c11692910a476081113b28e5ab SHA512 72000aeb85dccfa60c492166426f8ede3bdebd71ce221ca667e94859739926102fc65689bf1288328fad00b7193f2a356d098e65931c0008791a0eb2084dbe73
+MISC metadata.xml 732 BLAKE2B 0547a9360068981db23bed7749d4043fdb9e1d42da49043a1b986e67598a613e2af2b7261b06bdd2070ff8e1b6c37522a023520f71e18c7d1e44170e49ecf09e SHA512 3d138aa823f1fa2f8384dc4a29039c8f143c3ee77d8f2b410be55b01dafb402d6b678272e0766fae588c12a6816a6df57f84823d8196dd4e748b9ab01742e50a
diff --git a/dev-python/simplegeneric/metadata.xml b/dev-python/simplegeneric/metadata.xml
new file mode 100644
index 000000000000..643f937f62b8
--- /dev/null
+++ b/dev-python/simplegeneric/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ The simplegeneric module lets you define simple single-dispatch
+ generic functions, akin to Python's built-in generic functions like len(),
+ iter() and so on. However, instead of using specially-named methods, these
+ generic functions use simple lookup tables, akin to those used by
+ e.g. pickle.dump() and other generic functions found in the Python
+ standard library.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">simplegeneric</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild b/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..44f8201b6974
--- /dev/null
+++ b/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple generic functions for Python"
+HOMEPAGE="https://pypi.org/project/simplegeneric/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ esetup.py test
+}