summaryrefslogtreecommitdiff
path: root/dev-python/simplebayes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/simplebayes
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/simplebayes')
-rw-r--r--dev-python/simplebayes/Manifest3
-rw-r--r--dev-python/simplebayes/metadata.xml17
-rw-r--r--dev-python/simplebayes/simplebayes-1.5.7.ebuild28
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/simplebayes/Manifest b/dev-python/simplebayes/Manifest
new file mode 100644
index 000000000000..38157ec864ef
--- /dev/null
+++ b/dev-python/simplebayes/Manifest
@@ -0,0 +1,3 @@
+DIST simplebayes-1.5.7.tar.gz 19260 BLAKE2B 373820a19c1a3188f0dfb57cbe6ac8e27fc6a96e9d1686d698a1f109122afd5240715678d965d843482de3c12b8b806157acef17008d4c6fac0103b343dd44d7 SHA512 417af72db13418e5a9df2fdb642fc63ed3eb4fbbf88cc7252a9e3603d31e35ccb68ae5838d8bb7d77554c1820a9db8aa944c639af4eb6418babb9d360ef3ddbc
+EBUILD simplebayes-1.5.7.ebuild 684 BLAKE2B e463905a8c9050e1bd28144616987c5b7b36542c35a6e38515c01b09b2deebb7b4df7ce0ea62b81684bb919391442cffed1b9cc21198a431359aad6074ca9b15 SHA512 27983f035b72303d39668e8c8779cf8795dd465e58116f31419e0e7ec430d18dc9b0442f9315ab531eea6e6115d7771759cecae0180377216606d8a8d50d7fc2
+MISC metadata.xml 613 BLAKE2B d2456e6bcf0c65893658fe5f64edd2a407b394ef468f4afc9c7f7386042dca32602acc7ed9822dfa7445f6853d3ecba4579b397630d73a9dbe62389495386bad SHA512 ca6a18f6ef26a213a83f4dbd6fba4542c868365fc713f386a0ab92e4cb60a9faf0fa96f82bdabf81ec301745a63d35e821203ae67dc0e1b6ef3b18cadf50a97b
diff --git a/dev-python/simplebayes/metadata.xml b/dev-python/simplebayes/metadata.xml
new file mode 100644
index 000000000000..3b9be0dd1edc
--- /dev/null
+++ b/dev-python/simplebayes/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <longdescription lang="en">
+A memory-based, optional-persistence naïve bayesian text classifier.
+
+This work is heavily inspired by the python "redisbayes" module found here:
+[https://github.com/jart/redisbayes] and [https://pypi.org/project/redisbayes]
+ </longdescription>
+ <upstream>
+ <remote-id type="github">hickeroar/simplebayes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/simplebayes/simplebayes-1.5.7.ebuild b/dev-python/simplebayes/simplebayes-1.5.7.ebuild
new file mode 100644
index 000000000000..803dcc401434
--- /dev/null
+++ b/dev-python/simplebayes/simplebayes-1.5.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="memory-based, optional-persistence naive bayesian text classifier"
+HOMEPAGE="https://github.com/hickeroar/simplebayes"
+SRC_URI="https://github.com/hickeroar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}