summaryrefslogtreecommitdiff
path: root/dev-python/simplebayes/simplebayes-1.5.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /dev-python/simplebayes/simplebayes-1.5.8.ebuild
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'dev-python/simplebayes/simplebayes-1.5.8.ebuild')
-rw-r--r--dev-python/simplebayes/simplebayes-1.5.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/simplebayes/simplebayes-1.5.8.ebuild b/dev-python/simplebayes/simplebayes-1.5.8.ebuild
new file mode 100644
index 000000000000..efe01695e0b0
--- /dev/null
+++ b/dev-python/simplebayes/simplebayes-1.5.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="memory-based, optional-persistence naive bayesian text classifier"
+HOMEPAGE="https://github.com/hickeroar/simplebayes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}