summaryrefslogtreecommitdiff
path: root/dev-python/signedjson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/signedjson
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/signedjson')
-rw-r--r--dev-python/signedjson/Manifest3
-rw-r--r--dev-python/signedjson/metadata.xml16
-rw-r--r--dev-python/signedjson/signedjson-1.1.4.ebuild35
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/signedjson/Manifest b/dev-python/signedjson/Manifest
new file mode 100644
index 000000000000..c080a1ffefa5
--- /dev/null
+++ b/dev-python/signedjson/Manifest
@@ -0,0 +1,3 @@
+DIST signedjson-1.1.4.gh.tar.gz 12714 BLAKE2B 854f28074b82490bbeb6a0a0b3528d608b2ff6f5ff3cb52c913525b81f483afa6b4c8423dc25d9adaa3c3a9f269ec54409af0e7f8b5ddf3903e33a9b00c0dac8 SHA512 8928b9ecf1d6a9291a07bc3270ef57a824267ad45c114cfb720fc4db36415301f6bee26db9bb447e0051d3366c5471f718f37238bdd841bd06e73f5841f13ed6
+EBUILD signedjson-1.1.4.ebuild 839 BLAKE2B 92836acb38615a9b6fd88326d9bc9b0e2b80532724ea31c840e55a6691936a1ba780a522c07ea1f65ab366f795845f911436da71d0a56dac77b12d16942ac841 SHA512 9ed19cb75a7ccb5d7b07bdec429213a76a77dc9e6315daa3f00b1d488be4f3a80c18e3fda42e5789e6cb10760d80e42cc1866f912c428c14ed664f611bc0b03b
+MISC metadata.xml 532 BLAKE2B 8b29e244049e74a5e10313104a9988aca0027530d063a60f834810c5df64714aa9379bc7a3ea6c4295d3902b08a7edd1aa67a225ce0ac390d48092502edc0321 SHA512 a3f5eb78d5b711d4041e0031c71d367a0f611e5c28c001dc76bbb5c10a3d801b049c5b41d4d542489dcbe812b0a36a10874ceac714b34da0aff8c9bb4fcd9ccf
diff --git a/dev-python/signedjson/metadata.xml b/dev-python/signedjson/metadata.xml
new file mode 100644
index 000000000000..d52dc8df1afc
--- /dev/null
+++ b/dev-python/signedjson/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>arkamar@atlas.cz</email>
+ <name>Petr Vaněk</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">signedjson</remote-id>
+ <remote-id type="github">matrix-org/python-signedjson</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/signedjson/signedjson-1.1.4.ebuild b/dev-python/signedjson/signedjson-1.1.4.ebuild
new file mode 100644
index 000000000000..ddefed8ba9e7
--- /dev/null
+++ b/dev-python/signedjson/signedjson-1.1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signs JSON objects with ED25519 signatures."
+HOMEPAGE="
+ https://github.com/matrix-org/python-signedjson
+ https://pypi.python.org/pypi/signedjson
+"
+SRC_URI="https://github.com/matrix-org/python-signedjson/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+S="${WORKDIR}/python-${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/canonicaljson[${PYTHON_USEDEP}]
+ dev-python/pynacl[${PYTHON_USEDEP}]
+ dev-python/unpaddedbase64[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_9)
+"
+
+distutils_enable_tests unittest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}