summaryrefslogtreecommitdiff
path: root/dev-python/shutilwhich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/shutilwhich
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/shutilwhich')
-rw-r--r--dev-python/shutilwhich/Manifest3
-rw-r--r--dev-python/shutilwhich/metadata.xml21
-rw-r--r--dev-python/shutilwhich/shutilwhich-1.1.0.ebuild20
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/shutilwhich/Manifest b/dev-python/shutilwhich/Manifest
new file mode 100644
index 000000000000..35a5f1ed17e0
--- /dev/null
+++ b/dev-python/shutilwhich/Manifest
@@ -0,0 +1,3 @@
+DIST shutilwhich-1.1.0.tar.gz 2300 BLAKE2B 0b510fe364991bcb1b2a627368e0aba23550a60dd0c8f892dbf25b5f23696f49ceedec487d91cc6a5acaffe28c29f635bacc633cc3c3377799fa8c75bd8bcd4d SHA512 94001875c428ce1ad1c92e5f5be1ed497630ac0e2221dbb93fde8438f128f4f2663a0a13e17b94852e4813aadec694fa21c24f647500e8053c89ec610eb7fe21
+EBUILD shutilwhich-1.1.0.ebuild 508 BLAKE2B 4a8ec8e9196227c9ebf92b095a01a5713a32e35d9f455b594a536b43bfb15ef85cdb0eb02b8905e39a7f9b1033216b8e03f47fb27d34d5ab577ede8ca91a2025 SHA512 a3596780a5ecd7c13edbcbb7cddefa97aad02865ff69738877d640c2be31ee63543faf7638a8c6e0acd1c1fd56ead2a459b87352d7ecc4ac41464da8489cb723
+MISC metadata.xml 711 BLAKE2B cf4caeca6cba1b6211e4910618287135ca84240d348595c91389578a2e2f887c1f88ebabcbf3960d0d6472169cd1b65455d1d8a4b58fcfa530662f75f29ffef4 SHA512 69223961a781434b4877e7648f9f2897c1dcb110a559e64dfcdfb6c26a696f8aeee4be1fa211e07baa01f1c9bf57f3ef44d43502a6635841e14e45ae524169e9
diff --git a/dev-python/shutilwhich/metadata.xml b/dev-python/shutilwhich/metadata.xml
new file mode 100644
index 000000000000..cdb140420308
--- /dev/null
+++ b/dev-python/shutilwhich/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>git@marcbrinkmann.de</email>
+ <name>Marc Brinkmann</name>
+ </maintainer>
+ <remote-id type="pypi">shutilwhich</remote-id>
+ <remote-id type="github">mbr/shutilwhich</remote-id>
+ </upstream>
+ <longdescription>
+ shutilwhich will monkey-patch the shutil package, so from that
+ point on you can simply import the which function. On Python
+ 3.3 and above, the module never do anything but return the
+ stdlib shutil.which function.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/shutilwhich/shutilwhich-1.1.0.ebuild b/dev-python/shutilwhich/shutilwhich-1.1.0.ebuild
new file mode 100644
index 000000000000..fbad293f2c08
--- /dev/null
+++ b/dev-python/shutilwhich/shutilwhich-1.1.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A copy & paste backport of Python 3.3's shutil.which function"
+HOMEPAGE="https://pypi.org/project/shutilwhich/ https://github.com/mbr/shutilwhich"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""