summaryrefslogtreecommitdiff
path: root/dev-python/shiboken
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/shiboken
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/shiboken')
-rw-r--r--dev-python/shiboken/Manifest6
-rw-r--r--dev-python/shiboken/files/1.2.2-Fix-tests-with-Python-3.patch49
-rw-r--r--dev-python/shiboken/files/rpath.cmake10
-rw-r--r--dev-python/shiboken/files/shiboken-1.2.2-gcc6.patch20
-rw-r--r--dev-python/shiboken/metadata.xml8
-rw-r--r--dev-python/shiboken/shiboken-1.2.2.ebuild91
6 files changed, 184 insertions, 0 deletions
diff --git a/dev-python/shiboken/Manifest b/dev-python/shiboken/Manifest
new file mode 100644
index 000000000000..a53b3a002aff
--- /dev/null
+++ b/dev-python/shiboken/Manifest
@@ -0,0 +1,6 @@
+AUX 1.2.2-Fix-tests-with-Python-3.patch 1864 BLAKE2B d58b9739fde1b3b4c8f588d500de8009145e2de71ff13384f75827d8b2623f62af599d8d8fa360343cf5fa02eb73ba79627c8a36892db08f45aeec45b6cd720a SHA512 969972ed55360ebaa5db68c81467b71d579ea03a0e1f7a21227bc8e3500289be7f6bcf2df6676a2449e19cf1a28f74a29dcd3c6a26817712814790cfd3a3d571
+AUX rpath.cmake 393 BLAKE2B 5e67bc306f6f16b7ea10d223d41f77bd12d4dceae5d7aaa2dfe96caa989412e52accf66061bdf2fe3abf9bed193894f5dffa87280ac13be54a0849a13d3f36c4 SHA512 b9f2d3b34fd31a7e289e3aa1c96110f92bc66f45e5bfaf796f86d52eb832e960caca0e314b87248d0a41c13c95f04402607cbb5ad7d0b3238d5bab5580c3a65f
+AUX shiboken-1.2.2-gcc6.patch 463 BLAKE2B c7880ffb782aa32a2ab3238116311e2f967c2eacd4fea8548588a2d393156090f8fcf41957194019481739c7e99a06ee53982b9a568426d5333e58b73a99d1c4 SHA512 ebea09b697bba76bc909dc61cfaabc50d2220c0ebbdcc9004b20bc9bf2f088685767f0d105cf07be77283714dfd5ad766239813dd2f6926c5d104abd528a702d
+DIST shiboken-1.2.2.tar.bz2 1073776 BLAKE2B 162e0e6d6bb53d09e4dbe9abf8ac310cd7913ba2e4440681cf98f16b8ee63a577759a1a3669bfb7e37b712a4c1dd638f54d571aadeae07578d377bdb1f161bb5 SHA512 9f5c1219ce699df6b5ee4bd68cf422cb69476bd062346fcc8b4d34d314001ba60dbd52a73d772aec16285a0aabb600034630beba754ca54f5e6a4b744a720073
+EBUILD shiboken-1.2.2.ebuild 2058 BLAKE2B facdfb9b1f5d4697f1fd6a8679c176cbf28618a39dc5e0c5a661aba5856781ae31e093b8824775493227947da9622e08f17e4c75931d73115d202a676214780e SHA512 31d48bc4bc5a0e468246a11adc7c79b8fd6109f631c20431a2eb875d025c71aff50f60fe2aba3ba75e8cba513f67700c75a88689548f39bf0fc757c27b00a3bf
+MISC metadata.xml 253 BLAKE2B 135681de74058b17bbf3526a1ba19e1536ef15e29c9088d5e5981a23a5aec6c46304882a43f00d9ed963af78aeb9c9f5f4eed7339dda4bd9eb10583ed6451aee SHA512 5417d2869e029c2e156185a3263bef4e78109b9306575cfcf072105a61ad2f75ee7bc6401db3564c1ae5c7630aadf551e09234b4448cd64341380f687ee47436
diff --git a/dev-python/shiboken/files/1.2.2-Fix-tests-with-Python-3.patch b/dev-python/shiboken/files/1.2.2-Fix-tests-with-Python-3.patch
new file mode 100644
index 000000000000..48e401d1be1d
--- /dev/null
+++ b/dev-python/shiboken/files/1.2.2-Fix-tests-with-Python-3.patch
@@ -0,0 +1,49 @@
+From 7f793442316599ca25014a3d39c5de56c384990f Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Fri, 23 May 2014 18:10:20 +1000
+Subject: [PATCH] Fix tests with Python 3.
+
+Change-Id: Ibbf54406ba33dd1f645a46d63c04269868288768
+---
+ tests/minimalbinding/typedef_test.py | 2 +-
+ tests/samplebinding/overflow_test.py | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/tests/minimalbinding/typedef_test.py b/tests/minimalbinding/typedef_test.py
+index 089b279..b5535fb 100644
+--- a/tests/minimalbinding/typedef_test.py
++++ b/tests/minimalbinding/typedef_test.py
+@@ -30,7 +30,7 @@ from py3kcompat import IS_PY3K
+
+ try:
+ import numpy as np
+-except ImportError, e:
++except ImportError:
+ np = None
+
+
+diff --git a/tests/samplebinding/overflow_test.py b/tests/samplebinding/overflow_test.py
+index 5020872..c294c13 100644
+--- a/tests/samplebinding/overflow_test.py
++++ b/tests/samplebinding/overflow_test.py
+@@ -45,7 +45,7 @@ class OverflowTest(unittest.TestCase):
+ '''C++ function receives an long long argument and raise OverflowError if the value is negative.'''
+ val = 100
+ self.assertEqual(doubleLongLong(val), 2 * val)
+- val = long(100)
++ val = int(100)
+ self.assertEqual(doubleLongLong(val), 2 * val)
+ val = (2 << 64) + 1
+ self.assertRaises(OverflowError, doubleLongLong, val)
+@@ -54,7 +54,7 @@ class OverflowTest(unittest.TestCase):
+ '''C++ function receives an unsigned long long argument and raise OverflowError if the value is negative.'''
+ val = 100
+ self.assertEqual(doubleUnsignedLongLong(val), 2 * val)
+- val = long(100)
++ val = int(100)
+ self.assertEqual(doubleUnsignedLongLong(val), 2 * val)
+ val *= -1
+ self.assertRaises(OverflowError, doubleUnsignedLongLong, val)
+--
+2.1.0
+
diff --git a/dev-python/shiboken/files/rpath.cmake b/dev-python/shiboken/files/rpath.cmake
new file mode 100644
index 000000000000..b896c8789185
--- /dev/null
+++ b/dev-python/shiboken/files/rpath.cmake
@@ -0,0 +1,10 @@
+# use, i.e. don't skip the full RPATH for the build tree
+SET(CMAKE_SKIP_BUILD_RPATH FALSE)
+
+# when building, don't use the install RPATH already
+# (but later on when installing)
+SET(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
+
+# add the automatically determined parts of the RPATH
+# which point to directories outside the build tree to the install RPATH
+SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
diff --git a/dev-python/shiboken/files/shiboken-1.2.2-gcc6.patch b/dev-python/shiboken/files/shiboken-1.2.2-gcc6.patch
new file mode 100644
index 000000000000..65734232472c
--- /dev/null
+++ b/dev-python/shiboken/files/shiboken-1.2.2-gcc6.patch
@@ -0,0 +1,20 @@
+Bug: https://bugs.gentoo.org/619332
+PR: https://github.com/pyside/Shiboken/pull/84
+
+--- a/tests/libsample/simplefile.cpp
++++ b/tests/libsample/simplefile.cpp
+@@ -90,13 +90,13 @@ bool
+ SimpleFile::exists() const
+ {
+ std::ifstream ifile(p->m_filename);
+- return ifile;
++ return static_cast<bool>(ifile);
+ }
+
+ bool
+ SimpleFile::exists(const char* filename)
+ {
+ std::ifstream ifile(filename);
+- return ifile;
++ return static_cast<bool>(ifile);
+ }
diff --git a/dev-python/shiboken/metadata.xml b/dev-python/shiboken/metadata.xml
new file mode 100644
index 000000000000..a7f1abb3029b
--- /dev/null
+++ b/dev-python/shiboken/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/shiboken/shiboken-1.2.2.ebuild b/dev-python/shiboken/shiboken-1.2.2.ebuild
new file mode 100644
index 000000000000..038b7b41135e
--- /dev/null
+++ b/dev-python/shiboken/shiboken-1.2.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit cmake-utils multilib python-r1
+
+DESCRIPTION="A tool for creating Python bindings for C++ libraries"
+HOMEPAGE="http://qt-project.org/wiki/PySide"
+SRC_URI="http://download.qt-project.org/official_releases/pyside/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-qt/qtcore:4
+ dev-qt/qtxmlpatterns:4
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/qtgui:4
+ dev-qt/qttest:4
+ )"
+
+DOCS=( AUTHORS ChangeLog )
+PATCHES=(
+ "${FILESDIR}/${PV}-Fix-tests-with-Python-3.patch"
+ "${FILESDIR}/${P}-gcc6.patch"
+)
+
+src_prepare() {
+ # Fix inconsistent naming of libshiboken.so and ShibokenConfig.cmake,
+ # caused by the usage of a different version suffix with python >= 3.2
+ sed -i -e "/get_config_var('SOABI')/d" \
+ cmake/Modules/FindPython3InterpWithDebug.cmake || die
+
+ if use prefix; then
+ cp "${FILESDIR}"/rpath.cmake . || die
+ sed -i -e '1iinclude(rpath.cmake)' CMakeLists.txt || die
+ fi
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ configuration() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build test TESTS)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_SITE_PACKAGES="$(python_get_sitedir)"
+ -DPYTHON_SUFFIX="-${EPYTHON}"
+ )
+
+ if [[ ${EPYTHON} == python3* ]]; then
+ mycmakeargs+=(
+ -DUSE_PYTHON3=ON
+ -DPYTHON3_EXECUTABLE="${PYTHON}"
+ -DPYTHON3_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON3_LIBRARY="$(python_get_library_path)"
+ )
+ fi
+
+ cmake-utils_src_configure
+ }
+ python_foreach_impl configuration
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_compile
+}
+
+src_test() {
+ python_foreach_impl cmake-utils_src_test
+}
+
+src_install() {
+ installation() {
+ cmake-utils_src_install
+ mv "${ED}"usr/$(get_libdir)/pkgconfig/${PN}{,-${EPYTHON}}.pc || die
+ }
+ python_foreach_impl installation
+}