summaryrefslogtreecommitdiff
path: root/dev-python/shiboken6
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-13 12:04:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-13 12:04:20 +0100
commitd993571e2ee444d08f4e9e90d493ee37338657e3 (patch)
tree5a49a1d4ceffe800051e363f64571c3b6735d2f7 /dev-python/shiboken6
parent266d65d0cceeb55ab2cc3bf4e465d7f35502a900 (diff)
gentoo auto-resync : 13:04:2024 - 12:04:19
Diffstat (limited to 'dev-python/shiboken6')
-rw-r--r--dev-python/shiboken6/Manifest2
-rw-r--r--dev-python/shiboken6/shiboken6-6.7.0.ebuild179
2 files changed, 181 insertions, 0 deletions
diff --git a/dev-python/shiboken6/Manifest b/dev-python/shiboken6/Manifest
index 7545c354f73a..532b33933356 100644
--- a/dev-python/shiboken6/Manifest
+++ b/dev-python/shiboken6/Manifest
@@ -1,4 +1,6 @@
AUX shiboken6-6.3.1-no-strip.patch 1001 BLAKE2B c486f9423d4934c2305e8f3109f017dbebd568573469a2fced8da895fbc61ef07a80e0d1c846e7a57988801d6ec4be05b86b46a8039e6702d667129a899fc137 SHA512 1f3e5b082a978e3ab8d8f4d9a5a0a661b8c063e2ece0221440abe342fbd45d566a384d588dbf00a1e469687f82da3728cd53e35d02077ce6a748d3747de3cec2
DIST pyside-setup-everywhere-src-6.6.2.tar.xz 13975896 BLAKE2B b4572e58613e5446692e8c4cef28156fd0126ecda0c6334652ce49c6c7ce4614dbf2400c693addaa38e9b6cca9e331b9fe84c83ddb26e7014b8603afe2c54ad6 SHA512 1d23d27a4cbe74434ec5d391172416d324b4c92181401444821b456b4e27dabbdb3dcaad685a22b62c09f750555a4e626bbb6406a2fbde1cf4ec5c8bbb64cda5
+DIST pyside-setup-everywhere-src-6.7.0.tar.xz 14382456 BLAKE2B 607e496cdeb7e55166b4f0dc15662a8792c7d8925856e8edbb927dfdc33342d158f430e3433d3d4a78ea33740e333fb2422ea1f4332408c3c6214f92d31bdd0d SHA512 7801d564d8d359edec431dc0e6f170538b9fc6f834cb7ab8eff41c1989bffb619c446d4d62d65db2a5b7592c0bff5d450d42de2797726658fe1a8f53df8a4c14
EBUILD shiboken6-6.6.2-r1.ebuild 6679 BLAKE2B 1ec39580ed7a65bb04a76b105c4d14009d881466d8a9484e79721122a6526a7a699ed7faf80d44047bbe63bbb81b7d87855cbbf5aa693d91b296cf96f4d1f871 SHA512 bef6b9f610e772d88bd16f9c920dec99f54c1cf29178fa4feb4c697eb071d386f800562d6155c08f051b3d7d36d89a324cd9299d914dae0fb51e393706e35d03
+EBUILD shiboken6-6.7.0.ebuild 6644 BLAKE2B e49d00898e1e064c422d9e2d2ef100ce92e5dd23482c0ff748f901909b7b267bfe37677f35bc5dfe5c7bf4bb90c5b5a2543e4dc9160f66ce6aec036686e01804 SHA512 b5c2df0719d1451ed9c0804e7b28dd62647b0f2ebcaacf9f16f07c816c76127bdb88402b58b6a63bdd2e95b0b4645e3c496dc855bc35a5475718b930184c4055
MISC metadata.xml 730 BLAKE2B 33e7e589d02ec0517e134aa50407ecb97c6800be3ab7b69174d65776f62c1f25c2b2209d51299d9e0110b5f5e9322ee2c0b43dc89e6b12c40ea322ca9bc8eb3f SHA512 cc4ecdd9bc86ce59c2027c6f87307d32bd76d5d2cd8c07edb6c60cc5317ea52a96136c7597a179d75f1632db2999300d8b8f0567679ba3fc562804774fcdcc98
diff --git a/dev-python/shiboken6/shiboken6-6.7.0.ebuild b/dev-python/shiboken6/shiboken6-6.7.0.ebuild
new file mode 100644
index 000000000000..1ef71d57974f
--- /dev/null
+++ b/dev-python/shiboken6/shiboken6-6.7.0.ebuild
@@ -0,0 +1,179 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: Split the "/usr/bin/shiboken6" binding generator from the
+# "/usr/lib64/libshiboken6-*.so" family of shared libraries. The former
+# requires everything (including Clang) at runtime; the latter only requires
+# Qt and Python at runtime. Note that "pip" separates these two as well. See:
+# https://doc.qt.io/qtforpython/shiboken6/faq.html#is-there-any-runtime-dependency-on-the-generated-binding
+# Once split, the PySide6 ebuild should be revised to require
+# "/usr/bin/shiboken6" at build time and "libshiboken6-*.so" at runtime.
+# TODO: Add PyPy once officially supported. See also:
+# https://bugreports.qt.io/browse/PYSIDE-535
+PYTHON_COMPAT=( python3_{10..12} )
+
+LLVM_COMPAT=( {15..18} )
+
+inherit cmake flag-o-matic llvm-r1 python-r1 toolchain-funcs
+
+MY_PN="pyside-setup-everywhere-src"
+
+DESCRIPTION="Python binding generator for C++ libraries"
+HOMEPAGE="https://wiki.qt.io/PySide6"
+SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-${PV}-src/${MY_PN}-${PV}.tar.xz"
+S="${WORKDIR}/${MY_PN}-${PV}/sources/shiboken6"
+
+# The "sources/shiboken6/libshiboken" directory is triple-licensed under the
+# GPL v2, v3+, and LGPL v3. All remaining files are licensed under the GPL v3
+# with version 1.0 of a Qt-specific exception enabling shiboken6 output to be
+# arbitrarily relicensed. (TODO)
+LICENSE="|| ( GPL-2 GPL-3+ LGPL-3 ) GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+docstrings numpy test vulkan"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Tests fail pretty bad and I'm not fixing them right now
+RESTRICT="test"
+
+# Minimal supported version of Qt.
+QT_PV="$(ver_cut 1-3)*:6"
+
+# Since Clang is required at both build- and runtime, BDEPEND is omitted here.
+RDEPEND="${PYTHON_DEPS}
+ =dev-qt/qtbase-${QT_PV}
+ $(llvm_gen_dep '
+ sys-devel/clang:${LLVM_SLOT}
+ sys-devel/llvm:${LLVM_SLOT}
+ ')
+ docstrings? (
+ >=dev-libs/libxml2-2.6.32
+ >=dev-libs/libxslt-1.1.19
+ )
+ numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ vulkan? ( dev-util/vulkan-headers )
+"
+DEPEND="${RDEPEND}
+ test? ( =dev-qt/qtbase-${QT_PV}[gui] )
+"
+# testlib is toggled by the gui flag on qtbase
+
+DOCS=( AUTHORS )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-6.3.1-no-strip.patch"
+)
+
+src_prepare() {
+ # TODO: File upstream issue requesting a sane way to disable NumPy support.
+ if ! use numpy; then
+ sed -i -e '/\bprint(os\.path\.realpath(numpy))/d' \
+ libshiboken/CMakeLists.txt || die
+ fi
+
+ # Shiboken6 assumes Vulkan headers live under either "$VULKAN_SDK/include"
+ # or "$VK_SDK_PATH/include" rather than "${EPREFIX}/usr/include/vulkan".
+ if use vulkan; then
+ sed -i -e "s~\bdetectVulkan(&headerPaths);~headerPaths.append(HeaderPath{QByteArrayLiteral(\"${EPREFIX}/usr/include/vulkan\"), HeaderType::System});~" \
+ ApiExtractor/clangparser/compilersupport.cpp || die
+ fi
+
+ local clangver="$(CPP=clang clang-major-version)"
+
+ # Clang 15 and older used the full version as a directory name.
+ if [[ ${clangver} -lt 16 ]]; then
+ clangver="$(CPP=clang clang-fullversion)"
+ fi
+
+ # Shiboken6 assumes the "/usr/lib/clang/${CLANG_NEWEST_VERSION}/include/"
+ # subdirectory provides Clang builtin includes (e.g., "stddef.h") for the
+ # currently installed version of Clang, where ${CLANG_NEWEST_VERSION} is
+ # the largest version specifier that exists under the "/usr/lib/clang/"
+ # subdirectory. This assumption is false in edge cases, including when
+ # users downgrade from newer Clang versions but fail to remove those
+ # versions with "emerge --depclean". See also:
+ # https://github.com/leycec/raiagent/issues/85
+ #
+ # Sadly, the clang-* family of functions exported by the "toolchain-funcs"
+ # eclass are defective, returning nonsensical placeholder strings if the
+ # end user has *NOT* explicitly configured their C++ compiler to be Clang.
+ # PySide6 does *NOT* care whether the end user has done so or not, as
+ # PySide6 unconditionally requires Clang in either case. See also:
+ # https://bugs.gentoo.org/619490
+ sed -i -e 's~(findClangBuiltInIncludesDir())~(QStringLiteral("'"${EPREFIX}"'/usr/lib/clang/'"${clangver}"'/include"))~' \
+ ApiExtractor/clangparser/compilersupport.cpp || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/925479
+ # https://bugreports.qt.io/browse/PYSIDE-2619
+ filter-lto
+
+ # Minimal tests for now, 2 failing with the extended version
+ # FIXME Subscripted generics cannot be used with class and instance checks
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DDISABLE_DOCSTRINGS=$(usex !docstrings)
+ )
+
+ shiboken6_configure() {
+ local mycmakeargs=(
+ "${mycmakeargs[@]}"
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
+ -DUSE_PYTHON_VERSION="${EPYTHON#python}"
+ -DFORCE_LIMITED_API=OFF
+ )
+ # CMakeLists.txt expects LLVM_INSTALL_DIR as an environment variable.
+ local -x LLVM_INSTALL_DIR="$(get_llvm_prefix)"
+ cmake_src_configure
+ }
+ python_foreach_impl shiboken6_configure
+}
+
+src_compile() {
+ python_foreach_impl cmake_src_compile
+}
+
+src_test() {
+ python_foreach_impl cmake_src_test
+}
+
+src_install() {
+ shiboken6_install() {
+ cmake_src_install
+ python_optimize
+
+ # Uniquify the "shiboken6" executable for the current Python target,
+ # preserving an unversioned "shiboken6" file arbitrarily associated
+ # with the last Python target.
+ cp "${ED}"/usr/bin/${PN}{,-${EPYTHON}} || die
+
+ # Uniquify the Shiboken6 pkgconfig file for the current Python target,
+ # preserving an unversioned "shiboken6.pc" file arbitrarily associated
+ # with the last Python target. See also:
+ # https://github.com/leycec/raiagent/issues/73
+ cp "${ED}/usr/$(get_libdir)"/pkgconfig/${PN}{,-${EPYTHON}}.pc || die
+ }
+ python_foreach_impl shiboken6_install
+
+ # CMakeLists.txt installs a "Shiboken6Targets-gentoo.cmake" file forcing
+ # downstream consumers (e.g., PySide6) to target one "libshiboken6-*.so"
+ # library and one "shiboken6" executable linked to one Python interpreter.
+ # See also:
+ # https://bugreports.qt.io/browse/PYSIDE-1053
+ # https://github.com/leycec/raiagent/issues/74
+ sed -i \
+ -e 's~shiboken6-python[[:digit:]]\+\.[[:digit:]]\+~shiboken6${PYTHON_CONFIG_SUFFIX}~g' \
+ -e 's~/bin/shiboken6~/bin/shiboken6${PYTHON_CONFIG_SUFFIX}~g' \
+ "${ED}/usr/$(get_libdir)"/cmake/Shiboken6/Shiboken6Targets-${CMAKE_BUILD_TYPE,,}.cmake || die
+
+ # Remove the broken "shiboken_tool.py" script. By inspection, this script
+ # reduces to a noop. Moreover, this script raises the following exception:
+ # FileNotFoundError: [Errno 2] No such file or directory: '/usr/bin/../shiboken_tool.py': '/usr/bin/../shiboken_tool.py'
+ rm "${ED}"/usr/bin/shiboken_tool.py || die
+}