summaryrefslogtreecommitdiff
path: root/dev-python/shiboken2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-07 15:22:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-07 15:22:09 +0000
commit441369caa3d11703d0349d4b9746b7ad10aa6cb2 (patch)
tree5d36ced6c5c7c609bcca67e1cfe9f4125237185f /dev-python/shiboken2
parent85ba3f2cfe9ff2b952efb1f3c3c08840f8093246 (diff)
gentoo auto-resync : 07:11:2022 - 15:22:08
Diffstat (limited to 'dev-python/shiboken2')
-rw-r--r--dev-python/shiboken2/Manifest2
-rw-r--r--dev-python/shiboken2/shiboken2-5.15.7.ebuild174
2 files changed, 176 insertions, 0 deletions
diff --git a/dev-python/shiboken2/Manifest b/dev-python/shiboken2/Manifest
index 2b5fcb5727da..7a05b0650ece 100644
--- a/dev-python/shiboken2/Manifest
+++ b/dev-python/shiboken2/Manifest
@@ -4,5 +4,7 @@ AUX shiboken2-5.15.5-python311-2.patch 2056 BLAKE2B c93be29e31b0fa6ce28a29de0dc4
AUX shiboken2-5.15.5-python311-3.patch 2363 BLAKE2B 84521be2008dda0fc9398dac2c6e235d0d976c3219f7ecf50f28938a7cce6952ec41795c2c86d0f71ccd94210661dc22a471adb2f879a133e11a3148923fd708 SHA512 540ff5afbfebcc00f20c43993f67458013f4655c06505fdf23bc26085bd2c621863dd9c28be1a20dca299113aee828974f853b145818fdb11d59fc12d0bb8c14
AUX shiboken2-5.15.6-fix-pyside2-compile.patch 422 BLAKE2B bdb66c4ef26fccf4b9f4bc4586fb7ffdd8dfed80bf6315a70c86882f98250e42235ff27265b6c3a4e65e8dd7b233b61201a33808985ffb50e929bc8b5deb864f SHA512 4f608eb93fb72f81a9327699b14d4451261831f5079fac12aa88ce17ac30fc846bd9b461b8f6a4780727507b388f675a116f55ef1c240ced33d941315af4d21c
DIST pyside-setup-opensource-src-5.15.6.tar.xz 3580388 BLAKE2B 8a3b15d073bcbb0c6734f500ca906e56387cb8fc4bfcfd996304d71b54edd5f4568976049519ed26aa718bee9e43f59a0c4ef53837d5a341219b991a8527a800 SHA512 99a0c1a05e722cbf33128cf25742e61b92e151fdc05b79db9bafe778e024a0c6fc2886ee3d0b923ff681c55916f5c0eea4197f174432587fd662fba4390b26f4
+DIST pyside-setup-opensource-src-5.15.7.tar.xz 3581144 BLAKE2B 95b5720a5273c96b00bdf86b36734970991a29cf0db1e6fb2c00d7e671fbc4459b4434abc91a8a47ec5d8ba694bcdae5b57a52448908fdca25c348f9ee2b6c81 SHA512 9c551b47581e4f2671c4378f1a2c0d9e565b08edee74244a7704a2c94eef1e1041d23f0e388c07bdd61067e986340907cf80f4527257a9a706f7f07c497834c6
EBUILD shiboken2-5.15.6.ebuild 6693 BLAKE2B af9bbbe6711442a1526f4db11cd6660f6d93b1a4997a120dd55cbf2e3911c8c4b00de4961b609f4761d293568a47f63cf0a9f70a67c11c5e730c9d14762b2d5a SHA512 be0131579e928a32450636db2b49c370412f0c7652216a7db2e16697f00e3f2afb938540a82b51b8350c9853c30d0dc98314ba5f007503f364aaca7686680750
+EBUILD shiboken2-5.15.7.ebuild 6693 BLAKE2B faa982f9d9110ed648e36ec0f749efeacfb6d37c48ce85098f30193a48fae799498238c0bfc141e8e6b3409e84e26e1a47b78d780860d24f8a4c7a36afb37f71 SHA512 442b7ea87664653d0771b08e19e89bd561b2407ca9e3cf74cea48d1adcfc4ff5315eedea502afa19d2506a269eb060f137f66f696474376e4cd88682681c1f42
MISC metadata.xml 730 BLAKE2B 803b825adb9fcd4379b1e3fba57d6b1916a81ced12f3b3c7d3ddcd68a0c03e85fcf31d5b07a70deebe073f267fe93a0529f7ffb4b1a9508a2223894883044f3b SHA512 5a462077fee2bd3ac87ab79274be0a718fd9b273fca4946d2d2734cefdf5817e6b4dc478a828b3bc783c63e64a62a6662b482d61eefe57386c15f9703a57fb24
diff --git a/dev-python/shiboken2/shiboken2-5.15.7.ebuild b/dev-python/shiboken2/shiboken2-5.15.7.ebuild
new file mode 100644
index 000000000000..b0096bef9dc1
--- /dev/null
+++ b/dev-python/shiboken2/shiboken2-5.15.7.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: Split the "/usr/bin/shiboken2" binding generator from the
+# "/usr/lib64/libshiboken2-*.so" family of shared libraries. The former
+# requires everything (including Clang) at runtime; the latter only requires
+# Qt and Python at runtime. Note that "pip" separates these two as well. See:
+# https://doc.qt.io/qtforpython/shiboken2/faq.html#is-there-any-runtime-dependency-on-the-generated-binding
+# Once split, the PySide2 ebuild should be revised to require
+# "/usr/bin/shiboken2" at build time and "libshiboken2-*.so" at runtime.
+# TODO: Add PyPy once officially supported. See also:
+# https://bugreports.qt.io/browse/PYSIDE-535
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake llvm python-r1 toolchain-funcs
+
+MY_P=pyside-setup-opensource-src-${PV}
+
+DESCRIPTION="Python binding generator for C++ libraries"
+HOMEPAGE="https://wiki.qt.io/PySide2"
+SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-${PV}-src/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}/sources/shiboken2"
+
+# The "sources/shiboken2/libshiboken" directory is triple-licensed under the
+# GPL v2, v3+, and LGPL v3. All remaining files are licensed under the GPL v3
+# with version 1.0 of a Qt-specific exception enabling shiboken2 output to be
+# arbitrarily relicensed. (TODO)
+LICENSE="|| ( GPL-2 GPL-3+ LGPL-3 ) GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+docstrings numpy test vulkan"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Tests fail pretty bad and I'm not fixing them right now
+RESTRICT="test"
+
+# Minimal supported version of Qt.
+QT_PV="$(ver_cut 1-2)*:5"
+
+# Since Clang is required at both build- and runtime, BDEPEND is omitted here.
+LLVM_MAX_SLOT=15
+RDEPEND="${PYTHON_DEPS}
+ =dev-qt/qtcore-${QT_PV}
+ <sys-devel/clang-16:=
+ <sys-devel/clang-runtime-16:=
+ docstrings? (
+ >=dev-libs/libxml2-2.6.32
+ >=dev-libs/libxslt-1.1.19
+ =dev-qt/qtxml-${QT_PV}
+ =dev-qt/qtxmlpatterns-${QT_PV}
+ )
+ numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ vulkan? ( dev-util/vulkan-headers )
+"
+DEPEND="${RDEPEND}
+ test? ( =dev-qt/qttest-${QT_PV} )
+"
+
+DOCS=( AUTHORS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.15.5-python311-1.patch
+ "${FILESDIR}"/${PN}-5.15.5-python311-2.patch
+ "${FILESDIR}"/${PN}-5.15.5-python311-3.patch
+ "${FILESDIR}"/${PN}-5.15.6-fix-pyside2-compile.patch
+ "${FILESDIR}"/${PN}-5.15.5-add-numpy-1.23-compatibility.patch
+)
+
+# Ensure the path returned by get_llvm_prefix() contains clang as well.
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}"
+}
+
+src_prepare() {
+ # TODO: File upstream issue requesting a sane way to disable NumPy support.
+ if ! use numpy; then
+ sed -i -e '/\bprint(os\.path\.realpath(numpy))/d' \
+ libshiboken/CMakeLists.txt || die
+ fi
+
+ # Shiboken2 assumes Vulkan headers live under either "$VULKAN_SDK/include"
+ # or "$VK_SDK_PATH/include" rather than "${EPREFIX}/usr/include/vulkan".
+ if use vulkan; then
+ sed -i -e "s~\bdetectVulkan(&headerPaths);~headerPaths.append(HeaderPath{QByteArrayLiteral(\"${EPREFIX}/usr/include/vulkan\"), HeaderType::System});~" \
+ ApiExtractor/clangparser/compilersupport.cpp || die
+ fi
+
+ # Shiboken2 assumes the "/usr/lib/clang/${CLANG_NEWEST_VERSION}/include/"
+ # subdirectory provides Clang builtin includes (e.g., "stddef.h") for the
+ # currently installed version of Clang, where ${CLANG_NEWEST_VERSION} is
+ # the largest version specifier that exists under the "/usr/lib/clang/"
+ # subdirectory. This assumption is false in edge cases, including when
+ # users downgrade from newer Clang versions but fail to remove those
+ # versions with "emerge --depclean". See also:
+ # https://github.com/leycec/raiagent/issues/85
+ #
+ # Sadly, the clang-* family of functions exported by the "toolchain-funcs"
+ # eclass are defective, returning nonsensical placeholder strings if the
+ # end user has *NOT* explicitly configured their C++ compiler to be Clang.
+ # PySide2 does *NOT* care whether the end user has done so or not, as
+ # PySide2 unconditionally requires Clang in either case. See also:
+ # https://bugs.gentoo.org/619490
+ sed -i -e 's~(findClangBuiltInIncludesDir())~(QStringLiteral("'"${EPREFIX}"'/usr/lib/clang/'$(CPP=clang clang-fullversion)'/include"))~' \
+ ApiExtractor/clangparser/compilersupport.cpp || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Minimal tests for now, 2 failing with the extended version
+ # FIXME Subscripted generics cannot be used with class and instance checks
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DDISABLE_DOCSTRINGS=$(usex !docstrings)
+ )
+
+ shiboken2_configure() {
+ local mycmakeargs=(
+ "${mycmakeargs[@]}"
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DUSE_PYTHON_VERSION="${EPYTHON#python}"
+ )
+ # CMakeLists.txt expects LLVM_INSTALL_DIR as an environment variable.
+ local -x LLVM_INSTALL_DIR="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
+ cmake_src_configure
+ }
+ python_foreach_impl shiboken2_configure
+}
+
+src_compile() {
+ python_foreach_impl cmake_src_compile
+}
+
+src_test() {
+ python_foreach_impl cmake_src_test
+}
+
+src_install() {
+ shiboken2_install() {
+ cmake_src_install
+ python_optimize
+
+ # Uniquify the "shiboken2" executable for the current Python target,
+ # preserving an unversioned "shiboken2" file arbitrarily associated
+ # with the last Python target.
+ cp "${ED}"/usr/bin/${PN}{,-${EPYTHON}} || die
+
+ # Uniquify the Shiboken2 pkgconfig file for the current Python target,
+ # preserving an unversioned "shiboken2.pc" file arbitrarily associated
+ # with the last Python target. See also:
+ # https://github.com/leycec/raiagent/issues/73
+ cp "${ED}/usr/$(get_libdir)"/pkgconfig/${PN}{,-${EPYTHON}}.pc || die
+ }
+ python_foreach_impl shiboken2_install
+
+ # CMakeLists.txt installs a "Shiboken2Targets-gentoo.cmake" file forcing
+ # downstream consumers (e.g., PySide2) to target one "libshiboken2-*.so"
+ # library and one "shiboken2" executable linked to one Python interpreter.
+ # See also:
+ # https://bugreports.qt.io/browse/PYSIDE-1053
+ # https://github.com/leycec/raiagent/issues/74
+ sed -i \
+ -e 's~shiboken2-python[[:digit:]]\+\.[[:digit:]]\+~shiboken2${PYTHON_CONFIG_SUFFIX}~g' \
+ -e 's~/bin/shiboken2~/bin/shiboken2${PYTHON_CONFIG_SUFFIX}~g' \
+ "${ED}/usr/$(get_libdir)"/cmake/Shiboken2-${PV}/Shiboken2Targets-${CMAKE_BUILD_TYPE,,}.cmake || die
+
+ # Remove the broken "shiboken_tool.py" script. By inspection, this script
+ # reduces to a noop. Moreover, this script raises the following exception:
+ # FileNotFoundError: [Errno 2] No such file or directory: '/usr/bin/../shiboken_tool.py': '/usr/bin/../shiboken_tool.py'
+ rm "${ED}"/usr/bin/shiboken_tool.py || die
+}