summaryrefslogtreecommitdiff
path: root/dev-python/shapely
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-13 23:50:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-13 23:50:08 +0000
commitea8740cede74808fe1546789e18738612217bb97 (patch)
tree50a16d926ab0d05dd840e745118ff229fcaf0b78 /dev-python/shapely
parent06bb974d894b86598af155dc76a6fbd76c4fa30c (diff)
gentoo auto-resync : 13:01:2023 - 23:50:08
Diffstat (limited to 'dev-python/shapely')
-rw-r--r--dev-python/shapely/Manifest2
-rw-r--r--dev-python/shapely/shapely-1.8.5_p1.ebuild52
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/shapely/Manifest b/dev-python/shapely/Manifest
index 7bb012a8c466..77ed59667596 100644
--- a/dev-python/shapely/Manifest
+++ b/dev-python/shapely/Manifest
@@ -1,5 +1,3 @@
-DIST shapely-1.8.5.post1.gh.tar.gz 323178 BLAKE2B 05ff22f972446da340714548f5a2ad233f8bac8bb0710a8c5444dc44e7d5ad0d2c2d37bc3ddb987f57accd065c75c9627752a6c6cb3590621e39812674c678e9 SHA512 99a406833ebd13cb3f88fb710ed66f545a0b128d201e82ff381de0214cde38c685a622f78e964d6d41fc9ba096bc62e63bf9da04d216dedf2f96bb1e3496d48f
DIST shapely-2.0.0.gh.tar.gz 324420 BLAKE2B efe8aea8d9507bf2d2c31ca7dfaa6a531f71530243dd8c23046f4803d36e36b1636a07255c634fc5d6e30391aac260dcdaeb1f4c2aa73297a90f71134c1bbc15 SHA512 15e261901ada47ef2a9d2f213a2634152bc43799fd27421726b5e6525f91aef60c0bbc5f38e5185bf89ec795b5fa703688d2b08d4d3d14c9274515c5935157cb
-EBUILD shapely-1.8.5_p1.ebuild 985 BLAKE2B 294cdc4f4a462f3817c22ee0fae47e027cba2d65de6a66b1ea16d910bd1b8d3b3453ff4811598eef107d26b96c32eeca2e53bd8d5c32e1bb1610135363686a81 SHA512 b939dfa998f2f5032ca75a68f77be0d06fc0e6e382ec8ce393893b0145168e4513d74540f2c3a2bb3125b06ac4e4bf02aa2daac23f4a1c469166e6e17e812dfc
EBUILD shapely-2.0.0.ebuild 821 BLAKE2B 624b82058d56d70c62afbe572bd283f34835305cbf26684b35f7a7f43c8304432c2067babd6bed87c971f74b2679cdf757a9890f6c8088f2c2600c0c39bec581 SHA512 86d92cb5ba287be33941276c2a77885b02f9bf01303133d2dcc19852a8bae2ecc37e701990df2f1555f8afed3741f959e30e7901a1e981875a4ba24a449b1bd0
MISC metadata.xml 1000 BLAKE2B 9be4c31c417a5660338f479aee97ec224a420cbd1ebd665ff4269a9920e16a5d78b494790bd1450ceb8be0d1228666cb5f7559b76abc669b8a15e61fb683a38a SHA512 044961ebb0caebfdacfd130fa5ed132b3ce59d0f3343c76d394e2e1cd5544bc23d3013e5b206597960f514da0203d59759a115daeab1291b6ce40ca5bdce6c8a
diff --git a/dev-python/shapely/shapely-1.8.5_p1.ebuild b/dev-python/shapely/shapely-1.8.5_p1.ebuild
deleted file mode 100644
index 8aa5d69f4d98..000000000000
--- a/dev-python/shapely/shapely-1.8.5_p1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-MY_P=${P/_p/.post}
-DESCRIPTION="Geometric objects, predicates, and operations"
-HOMEPAGE="
- https://pypi.org/project/Shapely/
- https://github.com/shapely/shapely/
-"
-SRC_URI="
- https://github.com/shapely/shapely/archive/${PV/_p/.post}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-DEPEND="
- >=sci-libs/geos-3.9
-"
-RDEPEND="
- ${DEPEND}
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${DEPEND}
- >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/matplotlib
-
-src_prepare() {
- rm -r _vendor || die
- sed -i -e 's:_vendor\.::' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- rm -rf shapely || die
- epytest
-}