summaryrefslogtreecommitdiff
path: root/dev-python/shapely
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-31 15:02:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-31 15:02:11 +0000
commite860dfa5acdb67f8e2b8938b005dbaaaaf2c984a (patch)
tree38fd83ad8fb940fa7c8b31bc24cda66c9346ca80 /dev-python/shapely
parente9bf3526a3a5e02396f24203bf8535a21b6f9784 (diff)
gentoo auto-resync : 31:01:2023 - 15:02:11
Diffstat (limited to 'dev-python/shapely')
-rw-r--r--dev-python/shapely/Manifest2
-rw-r--r--dev-python/shapely/shapely-2.0.1.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/shapely/Manifest b/dev-python/shapely/Manifest
index 4d0814a25905..d145d2467d86 100644
--- a/dev-python/shapely/Manifest
+++ b/dev-python/shapely/Manifest
@@ -1,3 +1,5 @@
DIST shapely-2.0.0.gh.tar.gz 324420 BLAKE2B efe8aea8d9507bf2d2c31ca7dfaa6a531f71530243dd8c23046f4803d36e36b1636a07255c634fc5d6e30391aac260dcdaeb1f4c2aa73297a90f71134c1bbc15 SHA512 15e261901ada47ef2a9d2f213a2634152bc43799fd27421726b5e6525f91aef60c0bbc5f38e5185bf89ec795b5fa703688d2b08d4d3d14c9274515c5935157cb
+DIST shapely-2.0.1.gh.tar.gz 325843 BLAKE2B f6ae72c8544c236f6761be5bbc358161232319377a76d297eda317e61b97185ae62126b27963cb83798593ec2ce3f29d99bd74113e356b69b54da7586927d43b SHA512 878a4857f5408e2f779566f4885b3336eecd2ecfd685e9be3e306af2720ca4da3f7a1159ae65ad1eba441e0f9b347176d6c144563a9562ed8213e6f964d183c7
EBUILD shapely-2.0.0.ebuild 821 BLAKE2B e3be3160db84be2174bff5e854731f6302e17986b0922fa013d6ac1a7d51d7c80d986a80b8b1909191b2f6f0140512debed2ff75e1cf8e7c25181c87b5b9d891 SHA512 c1c1d364a80f89521aa2f56d1ab7fa3380653da2b3285cc615b788fd173d6878c243d7bd3592128e2a04c112e29e633ff2c37361f5916f892dd6b79106d76791
+EBUILD shapely-2.0.1.ebuild 823 BLAKE2B 1ac755e0ad6191781a6b18badca90af57e59920cfc2580a7b74772637b53d69bde223d6a02f8032584067f579017be88632bed461665b6f7d65848bfec315d21 SHA512 2b95c346800b8c0d1829a2a6219c9814e0ebf9b45bc272175babb7275dc183fa3502786740f235a211495d8cb4390aecc11305c4abe9f729c73655826601e06e
MISC metadata.xml 1000 BLAKE2B 9be4c31c417a5660338f479aee97ec224a420cbd1ebd665ff4269a9920e16a5d78b494790bd1450ceb8be0d1228666cb5f7559b76abc669b8a15e61fb683a38a SHA512 044961ebb0caebfdacfd130fa5ed132b3ce59d0f3343c76d394e2e1cd5544bc23d3013e5b206597960f514da0203d59759a115daeab1291b6ce40ca5bdce6c8a
diff --git a/dev-python/shapely/shapely-2.0.1.ebuild b/dev-python/shapely/shapely-2.0.1.ebuild
new file mode 100644
index 000000000000..6c31a645aa99
--- /dev/null
+++ b/dev-python/shapely/shapely-2.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="
+ https://pypi.org/project/shapely/
+ https://github.com/shapely/shapely/
+"
+SRC_URI="
+ https://github.com/shapely/shapely/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=sci-libs/geos-3.9
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_compile_all() {
+ rm -r shapely || die
+}