summaryrefslogtreecommitdiff
path: root/dev-python/shapely
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-10 12:09:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-10 12:09:13 +0100
commit35d60f48c1e8e3d48626e53a1933c55805177d20 (patch)
tree0754900eff547564866e4e7265a5f0789874f907 /dev-python/shapely
parentdd14643cac4a1aa6ce4151cea5c424577434968b (diff)
gentoo auto-resync : 10:10:2023 - 12:09:13
Diffstat (limited to 'dev-python/shapely')
-rw-r--r--dev-python/shapely/Manifest2
-rw-r--r--dev-python/shapely/files/shapely-2.0.1-cython3.patch30
-rw-r--r--dev-python/shapely/shapely-2.0.1-r1.ebuild56
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/shapely/Manifest b/dev-python/shapely/Manifest
index 81b8c02364f6..561b7f492d94 100644
--- a/dev-python/shapely/Manifest
+++ b/dev-python/shapely/Manifest
@@ -1,3 +1,5 @@
+AUX shapely-2.0.1-cython3.patch 894 BLAKE2B d6bdb6a31b5d574ac1fd08066a053792eeea4cac38155ced2b6f9596aec65ade7f6453ce2197eee797540582c523adc1a2a25723019518508939f9679054ec4e SHA512 dceb1f6e046fc291e0e6423fd494fc6033c0b1f39dd92db8f27b5773a3389e71c6aaecdb837ac73e57a9b85ce3d30f58050e338e497d6baaa7bc017ff846b84a
DIST shapely-2.0.1.gh.tar.gz 325843 BLAKE2B f6ae72c8544c236f6761be5bbc358161232319377a76d297eda317e61b97185ae62126b27963cb83798593ec2ce3f29d99bd74113e356b69b54da7586927d43b SHA512 878a4857f5408e2f779566f4885b3336eecd2ecfd685e9be3e306af2720ca4da3f7a1159ae65ad1eba441e0f9b347176d6c144563a9562ed8213e6f964d183c7
+EBUILD shapely-2.0.1-r1.ebuild 1157 BLAKE2B a0a40f4bbee053c96b18c2f0a6784fbbb501582a2ef46910fae2bae253f939aa764f1d3a0039322b08a07a321a4c5f1e29a69c200d7671c177fe8230d70072b3 SHA512 a1f81501c79e722121d24fcc16988e974a09fcec8574de377af69f68b130ca5103fc5a5913b532e5dd97e53d0a08d89b2e4a0f261b2fc86a5f5a439fb92112f6
EBUILD shapely-2.0.1.ebuild 923 BLAKE2B 38be0cd4a8549a91e50671a4a9e3a8c3a2c97d3ef2eab89cf790b79b1c8f32b3d016d66c9f9a7947ce55968228f5143777ce188e8f4a46b7e9fc9515d5b1e6f6 SHA512 c6249cd47a7c06f9841f69c0edfed2cb30cb78c8731f58c92a89cf9e0b98a73f98097a46dad6dfe5d3a25ae1a4673625e9a8511edeb933bcf8df020672f2cf10
MISC metadata.xml 1000 BLAKE2B 9be4c31c417a5660338f479aee97ec224a420cbd1ebd665ff4269a9920e16a5d78b494790bd1450ceb8be0d1228666cb5f7559b76abc669b8a15e61fb683a38a SHA512 044961ebb0caebfdacfd130fa5ed132b3ce59d0f3343c76d394e2e1cd5544bc23d3013e5b206597960f514da0203d59759a115daeab1291b6ce40ca5bdce6c8a
diff --git a/dev-python/shapely/files/shapely-2.0.1-cython3.patch b/dev-python/shapely/files/shapely-2.0.1-cython3.patch
new file mode 100644
index 000000000000..23fb0384e3f4
--- /dev/null
+++ b/dev-python/shapely/files/shapely-2.0.1-cython3.patch
@@ -0,0 +1,30 @@
+https://bugs.gentoo.org/898708
+https://github.com/shapely/shapely/pull/1872
+https://github.com/shapely/shapely/commit/fea6d0351a4422b1f9fefb508db7924981c18e43
+
+From fea6d0351a4422b1f9fefb508db7924981c18e43 Mon Sep 17 00:00:00 2001
+From: Joris Van den Bossche <jorisvandenbossche@gmail.com>
+Date: Sun, 8 Oct 2023 11:12:28 +0200
+Subject: [PATCH] Fix for cython 3 compatibility (#1872)
+
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,6 +1,6 @@
+ [build-system]
+ requires = [
+- "Cython~=0.29",
++ "Cython",
+ "oldest-supported-numpy",
+ "setuptools>=61.0.0",
+ ]
+--- a/shapely/_geos.pyx
++++ b/shapely/_geos.pyx
+@@ -8,7 +8,7 @@ import warnings
+ from shapely import GEOSException
+
+
+-cdef void geos_message_handler(const char* message, void* userdata):
++cdef void geos_message_handler(const char* message, void* userdata) noexcept:
+ snprintf(<char *>userdata, 1024, "%s", message)
+
+
diff --git a/dev-python/shapely/shapely-2.0.1-r1.ebuild b/dev-python/shapely/shapely-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..26da953c9be3
--- /dev/null
+++ b/dev-python/shapely/shapely-2.0.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="
+ https://pypi.org/project/shapely/
+ https://github.com/shapely/shapely/
+"
+SRC_URI="
+ https://github.com/shapely/shapely/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=sci-libs/geos-3.9
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.1-cython3.patch
+)
+
+EPYTEST_DESELECT=(
+ # Should be able to drop these in next release (>2.0.1)
+ # https://github.com/shapely/shapely/issues/1670
+ # https://github.com/shapely/shapely/issues/1855
+ tests/test_parallel_offset.py::OperationsTestCase::test_parallel_offset_linestring
+)
+
+distutils_enable_tests pytest
+
+python_compile_all() {
+ rm -r shapely || die
+}