summaryrefslogtreecommitdiff
path: root/dev-python/shapely/shapely-1.8.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-02 22:17:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-02 22:17:13 +0100
commitec321939a77843497c860196ea06d7776d94b755 (patch)
tree426c3b59f57bfb684b461e65c4416048b369b4ce /dev-python/shapely/shapely-1.8.4.ebuild
parent2982504d287f7f91eade76902f11e691f8181071 (diff)
gentoo auto-resync : 02:09:2022 - 22:17:13
Diffstat (limited to 'dev-python/shapely/shapely-1.8.4.ebuild')
-rw-r--r--dev-python/shapely/shapely-1.8.4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/shapely/shapely-1.8.4.ebuild b/dev-python/shapely/shapely-1.8.4.ebuild
new file mode 100644
index 000000000000..e123057db79a
--- /dev/null
+++ b/dev-python/shapely/shapely-1.8.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="
+ https://pypi.org/project/Shapely/
+ https://github.com/shapely/shapely/
+"
+SRC_URI="
+ https://github.com/shapely/shapely/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=sci-libs/geos-3.9
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/matplotlib
+
+src_prepare() {
+ rm -r _vendor || die
+ sed -i -e 's:_vendor\.::' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ rm -rf shapely || die
+ epytest
+}