summaryrefslogtreecommitdiff
path: root/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild')
-rw-r--r--dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
index 0747a0892490..94d423503545 100644
--- a/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
+++ b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
inherit distutils-r1
DESCRIPTION="A setuptools_scm plugin for git archives"
@@ -21,11 +21,13 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+distutils_enable_tests pytest
+
src_prepare() {
export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
distutils-r1_src_prepare
}
python_test() {
- esetup.py test
+ pytest tests.py || die
}