summaryrefslogtreecommitdiff
path: root/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild')
-rw-r--r--dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
index 04680a37ecf3..47aa91fa85d8 100644
--- a/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
+++ b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="A setuptools_scm plugin for git archives"
@@ -15,11 +15,10 @@ SLOT="0"
KEYWORDS="amd64 arm ~arm64 ~ppc64 x86"
IUSE=""
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
"
-RDEPEND="${DEPEND}"
+BDEPEND="${RDEPEND}"
distutils_enable_tests pytest
@@ -29,5 +28,5 @@ src_prepare() {
}
python_test() {
- pytest tests.py || die
+ epytest tests.py
}