summaryrefslogtreecommitdiff
path: root/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1-r5.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1-r5.ebuild')
-rw-r--r--dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1-r5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1-r5.ebuild b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1-r5.ebuild
new file mode 100644
index 000000000000..4324185e7ee2
--- /dev/null
+++ b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1-r5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A setuptools_scm plugin for git archives"
+HOMEPAGE="
+ https://github.com/Changaco/setuptools_scm_git_archive/
+ https://pypi.org/project/setuptools-scm-git-archive/
+"
+SRC_URI="
+ https://github.com/Changaco/setuptools_scm_git_archive/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+
+python_test() {
+ epytest tests.py
+}