summaryrefslogtreecommitdiff
path: root/dev-python/setuptools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-21 18:02:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-21 18:02:52 +0100
commitebd51986f51b430f84c569c6c0f2fe051158d444 (patch)
tree0f4e961f34bca6c29cb4defea06a6595fa460d58 /dev-python/setuptools
parentd1f1f3bc630772e7197391e85311655e2b6e7fa2 (diff)
gentoo auto-resync : 21:04:2023 - 18:02:52
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/Manifest2
-rw-r--r--dev-python/setuptools/setuptools-67.7.1.ebuild128
2 files changed, 130 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 96dd20972f52..ef074ad2c0e6 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -1,6 +1,8 @@
AUX setuptools-62.4.0-py-compile.patch 3704 BLAKE2B 9a5e70d2556b059be0ef060abd1db71298cd0e9aa1e2795d92cea5cdbaf0c82f4433e1a0c3095f4bc41bc72a457b63142253fe46c712afa1d7855a5d43607bca SHA512 48d7c065e2d8c29ce6e498effe6d79f9caa0f37d7cf6cadd0ed02c48d196a4d8a10a73cfa26744d6f74b48c63cd28a4074b161a6aae18c6169f6d8fffb044b1e
DIST setuptools-67.6.1.tar.gz 2486256 BLAKE2B 7827eec689b6a4463888137660489a29cd6aa67a14f0cf42ece78463788d74b97bd951b75c48c185c5c33d5bea29c44c8660649bf79035012bc75b915e9d0a42 SHA512 197910ad4c4058af0107e240d2e27bc2c1ff373cb3fba33af09eb3cc42614c45e4bb73a65802f253466eafd94517e08b51e98f50213817ad03d88ee0ccf9adbc
DIST setuptools-67.7.0.tar.gz 2491327 BLAKE2B 3d1e89cf5b2753883397ff3a668dbfcef41c57775bd1871ada69c11a7deffe53fd4c4036b5c98146ec0496b1be86df1522c64cc981acb5ec192bd93bd800c2de SHA512 39502337b5d7f710c55219ab970a5cab23e8987598af722ad231d2dea2e1dfaaddb09dc698a5746a719b36e5e3065c48ecee2ac428e4d41470bec6ad3c99daf6
+DIST setuptools-67.7.1.tar.gz 2491346 BLAKE2B 2eb89badcbfec51fb3deca5f4267036305569bf42677b87c9eeb7cecd902c121ffc6725506bfa0ba3ac50e06c036a520dd14b6193ff048e21ed80dfeb1c93602 SHA512 c90a6ad0c215540dfd93d5c88126dab15499deb80ed601f4a90c92dfdff5fed6ff168fb8e6b9dc5ba8b1f067114d383400df390b2eebd934e2e728c3b56886af
EBUILD setuptools-67.6.1.ebuild 4433 BLAKE2B ee7aad8ec1b5ff9d90c6a9e13f608d99b027b7a9e58b7dccc60459304637952c751b4bb6cbece6ccd9970540379bceccd3b8928fdb30065aafe193a4d4438122 SHA512 57327f340317249f788a008c73da4a1016886ed93cef877cf98d1eaa743cc4c42e05adb633fefb1d5d5691864ff27fa1b9a40885a1084fca21e523e0be6f69e7
EBUILD setuptools-67.7.0.ebuild 4441 BLAKE2B cfa4d721dcf277a97abbc33e5dd46160bd7f19f96da61569e8d7da81c00979de8ceb1e460e61827db8ff14682d04db213905342171ccf09ec87a9e5b33a441d9 SHA512 fda509a1bbe2f468ef2c6601ab9484ea1139e6593f6c33d35ad5a8a51e27f42904289617f552072a3022ca946d71cf39ecd01e25a52d623ca7274f21f0d979ef
+EBUILD setuptools-67.7.1.ebuild 4441 BLAKE2B cfa4d721dcf277a97abbc33e5dd46160bd7f19f96da61569e8d7da81c00979de8ceb1e460e61827db8ff14682d04db213905342171ccf09ec87a9e5b33a441d9 SHA512 fda509a1bbe2f468ef2c6601ab9484ea1139e6593f6c33d35ad5a8a51e27f42904289617f552072a3022ca946d71cf39ecd01e25a52d623ca7274f21f0d979ef
MISC metadata.xml 469 BLAKE2B 4a26769b09a3785586b22db850b7fc5c4818f31c3ace9cc94476d35df05e50edf6721f3c95ec615c3b2efe071ef284a54ea2d53566316ba653f7830bb48f80bf SHA512 dd682c4ad2e59a97094ebdabe4d1063e2319ed05e1fe9d8c2fafe069badb3b4cf8bb6d9f50e09d2128e2a081c1c69827407ac8aed644ebf70eb4ca1bc9a57319
diff --git a/dev-python/setuptools/setuptools-67.7.1.ebuild b/dev-python/setuptools/setuptools-67.7.1.ebuild
new file mode 100644
index 000000000000..dee75c752db8
--- /dev/null
+++ b/dev-python/setuptools/setuptools-67.7.1.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+# please bump dev-python/ensurepip-setuptools along with this package!
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_TESTED=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="
+ https://github.com/pypa/setuptools/
+ https://pypi.org/project/setuptools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/jaraco-text-3.7.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.12.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/nspektr-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/ordered-set-4.0.2-r1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3-r2[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.6.2-r1[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.11.1[${PYTHON_USEDEP}]
+ ' 3.9)
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-python/wheel-0.37.1-r1[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/ini2toml-0.9[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-envs-2.2[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-path-3.2.0[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pip-run[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/tomli-w-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+DOCS=( {CHANGES,README}.rst )
+
+src_prepare() {
+ local PATCHES=(
+ # TODO: remove this when we're 100% PEP517 mode
+ "${FILESDIR}"/setuptools-62.4.0-py-compile.patch
+ )
+
+ distutils-r1_src_prepare
+
+ # remove bundled dependencies, setuptools will switch to system deps
+ # automatically
+ rm -r */_vendor || die
+
+ # remove the ugly */extern hack that breaks on unvendored deps
+ rm -r */extern || die
+ find -name '*.py' -exec sed \
+ -e 's:from \w*[.]\+extern ::' -e 's:\w*[.]\+extern[.]::' \
+ -i {} + || die
+}
+
+python_test() {
+ local -x SETUPTOOLS_USE_DISTUTILS=stdlib
+
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ return
+ fi
+
+ local EPYTEST_DESELECT=(
+ # network
+ # TODO: see if PRE_BUILT_SETUPTOOLS_* helps
+ setuptools/tests/config/test_apply_pyprojecttoml.py::test_apply_pyproject_equivalent_to_setupcfg
+ setuptools/tests/integration/test_pip_install_sdist.py::test_install_sdist
+ setuptools/tests/test_build_meta.py::test_legacy_editable_install
+ setuptools/tests/test_distutils_adoption.py
+ setuptools/tests/test_editable_install.py
+ setuptools/tests/test_setuptools.py::test_its_own_wheel_does_not_contain_tests
+ setuptools/tests/test_virtualenv.py::test_clean_env_install
+ setuptools/tests/test_virtualenv.py::test_no_missing_dependencies
+ setuptools/tests/test_virtualenv.py::test_test_command_install_requirements
+ # TODO
+ setuptools/tests/config/test_setupcfg.py::TestConfigurationReader::test_basic
+ setuptools/tests/config/test_setupcfg.py::TestConfigurationReader::test_ignore_errors
+ setuptools/tests/test_extern.py::test_distribution_picklable
+ # expects bundled deps in virtualenv
+ setuptools/tests/config/test_apply_pyprojecttoml.py::TestMeta::test_example_file_in_sdist
+ setuptools/tests/config/test_apply_pyprojecttoml.py::TestMeta::test_example_file_not_in_wheel
+ setuptools/tests/test_editable_install.py::test_editable_with_pyproject
+ # fails if python-xlib is installed
+ setuptools/tests/test_easy_install.py::TestSetupRequires::test_setup_requires_with_allow_hosts
+ )
+
+ if has_version "<dev-python/packaging-22"; then
+ EPYTEST_DESELECT+=(
+ # old packaging is more lenient
+ setuptools/tests/config/test_setupcfg.py::TestOptions::test_raises_accidental_env_marker_misconfig
+ )
+ fi
+
+ epytest -n "$(makeopts_jobs)" setuptools
+}