summaryrefslogtreecommitdiff
path: root/dev-python/setuptools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
commit3e42d1577189af123b773dc0f11e5419035308c8 (patch)
tree95d77507c924544b12363e6da6aa741c444f3e8a /dev-python/setuptools
parent6243676c91946098c06d42bc87b5eb99aac40bf0 (diff)
gentoo auto-resync : 26:04:2024 - 23:59:36
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/Manifest3
-rw-r--r--dev-python/setuptools/setuptools-69.2.0-r2.ebuild130
-rw-r--r--dev-python/setuptools/setuptools-69.5.1-r1.ebuild (renamed from dev-python/setuptools/setuptools-69.5.1.ebuild)8
3 files changed, 138 insertions, 3 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index ccb0c90a255e..2f3f86444343 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -4,5 +4,6 @@ DIST setuptools-69.2.0.tar.gz 2222950 BLAKE2B 9f2bfee2bc6ca05c319137166d8b7a4fc8
DIST setuptools-69.5.1.tar.gz 2291314 BLAKE2B 3756dd587136c7e688bdfecf4c0434c0e799f50f9a9a95750d41cb75e26b613b3dc178f43a9e0d21f17c42a7c4ad7461e7986966aefb814e3d0ff05178c82542 SHA512 81f4a5184976a0d4aa070261bb56458c54ec6a479786fa469e98cb336e9a1691b281ae771abe41bc5398fac15b2dd039c07cf014ee00572f46908ce6830fcb6a
EBUILD setuptools-69.0.3-r1.ebuild 3942 BLAKE2B 7f198d6bf946f17df21143474c91c61be21ebde1c035f1dabdb78cf5308b978113bcb5f0d353ded961493ee8b0b9636f3354c6ac8fdc06bf16b75c2e12c32499 SHA512 170054320f5213dd0e9532836378415191796149bd6ea97824a4aad5019b5ee0e459b0a260aab176ae4cab8cc795d037ea29620d742f35b058d09e5ef5918136
EBUILD setuptools-69.2.0-r1.ebuild 4383 BLAKE2B fd8a9ddde671d272d0f9c333fcae05e54dd1b2e127e43c656f19b2d312bdfd2185ef6a984412154feec236bf1b910808017849a7d1726e5511d152233bf27af6 SHA512 1cc67aa39a272c1035e799e4eb6a9ff8448cdc2ac92c613055a05a18863bec5e1c5d73494e954f06f63fbfb3cd9f884d82d6297f6a3037e91d8875c1691cffcc
-EBUILD setuptools-69.5.1.ebuild 4485 BLAKE2B 9532bac99bfe97b3b9d7cf78c4230ada458f58ea23200fd14f7b2a1759eed988a669646671f1d0b38e1c065a7f83ef76146fed791212850c05f3ca3ec0279192 SHA512 da44436084e8191d376fb80589ca7ccc1279e00208b3d50499f9943a8ff4d91f7459b1b6e4b6d069a527b32ab02be2ddec3535e21b08fef390ee6aa2ceabbc28
+EBUILD setuptools-69.2.0-r2.ebuild 4486 BLAKE2B 00f65a2be08272c52afb38ce25aacda05a124b24b4e3f45d00985c65dfa628a008fbab4e1b6bf9d19d26eb4559602d4f9925dcf6c2e3eefd4a29caa5f1ec3abc SHA512 c0d1cb983d92dd3305552900f974fbd562f9290f09f90a5283a2faf8d53601fe8b0facb19b549bbde5bfbd67ac3b38237a0a3c23b403ebcfbbff8202f8bd6b95
+EBUILD setuptools-69.5.1-r1.ebuild 4580 BLAKE2B 0068a50e2d93f4f8cd8a7bb93f239157abf3cb410937999446c9e9808a6d6efdab01d1ddb2dbe21e856d5b7167cc9abc217ac310b949037e4bdd901ae1770d1a SHA512 f776196831087f083321e022c35387ebd121f67266ba81e044f697a6b7fc28e91347a74a2ce09444ccdf8a42dd294da73ddaeddfcfe1754252ca7251a843d7db
MISC metadata.xml 469 BLAKE2B 4a26769b09a3785586b22db850b7fc5c4818f31c3ace9cc94476d35df05e50edf6721f3c95ec615c3b2efe071ef284a54ea2d53566316ba653f7830bb48f80bf SHA512 dd682c4ad2e59a97094ebdabe4d1063e2319ed05e1fe9d8c2fafe069badb3b4cf8bb6d9f50e09d2128e2a081c1c69827407ac8aed644ebf70eb4ca1bc9a57319
diff --git a/dev-python/setuptools/setuptools-69.2.0-r2.ebuild b/dev-python/setuptools/setuptools-69.2.0-r2.ebuild
new file mode 100644
index 000000000000..d4b20999e641
--- /dev/null
+++ b/dev-python/setuptools/setuptools-69.2.0-r2.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+# please bump dev-python/ensurepip-setuptools along with this package!
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_TESTED=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="
+ https://github.com/pypa/setuptools/
+ https://pypi.org/project/setuptools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/jaraco-text-3.7.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.12.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/ordered-set-4.0.2-r1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-23.2[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.6.2-r1[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.37.1-r1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' python3_10 pypy3)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/importlib-metadata[${PYTHON_USEDEP}]
+ >=dev-python/ini2toml-0.9[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-envs-2.2[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-path-3.2.0[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pip-run[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/pytest-home-0.5[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-w-1.0.0[${PYTHON_USEDEP}]
+ ' python3_10 pypy3)
+ )
+"
+# setuptools-scm is here because installing plugins apparently breaks stuff at
+# runtime, so let's pull it early. See bug #663324.
+PDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ local PATCHES=(
+ # TODO: remove this when we're 100% PEP517 mode
+ "${FILESDIR}"/setuptools-62.4.0-py-compile.patch
+ )
+
+ distutils-r1_src_prepare
+
+ # remove bundled dependencies
+ rm -r */_vendor || die
+
+ # remove the ugly */extern hack that breaks on unvendored deps
+ rm -r */extern || die
+ find -name '*.py' -exec sed \
+ -e 's:from \w*[.]\+extern ::' -e 's:\w*[.]\+extern[.]::' \
+ -i {} + || die
+}
+
+python_test() {
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ return
+ fi
+
+ local EPYTEST_DESELECT=(
+ # network
+ # TODO: see if PRE_BUILT_SETUPTOOLS_* helps
+ setuptools/tests/config/test_apply_pyprojecttoml.py::test_apply_pyproject_equivalent_to_setupcfg
+ setuptools/tests/integration/test_pip_install_sdist.py::test_install_sdist
+ setuptools/tests/test_build_meta.py::test_legacy_editable_install
+ setuptools/tests/test_distutils_adoption.py
+ setuptools/tests/test_editable_install.py
+ setuptools/tests/test_setuptools.py::test_its_own_wheel_does_not_contain_tests
+ setuptools/tests/test_virtualenv.py::test_clean_env_install
+ setuptools/tests/test_virtualenv.py::test_no_missing_dependencies
+ setuptools/tests/test_virtualenv.py::test_test_command_install_requirements
+ # TODO
+ setuptools/tests/config/test_setupcfg.py::TestConfigurationReader::test_basic
+ setuptools/tests/config/test_setupcfg.py::TestConfigurationReader::test_ignore_errors
+ setuptools/tests/test_extern.py::test_distribution_picklable
+ # expects bundled deps in virtualenv
+ setuptools/tests/config/test_apply_pyprojecttoml.py::TestMeta::test_example_file_in_sdist
+ setuptools/tests/config/test_apply_pyprojecttoml.py::TestMeta::test_example_file_not_in_wheel
+ # fails if python-xlib is installed
+ setuptools/tests/test_easy_install.py::TestSetupRequires::test_setup_requires_with_allow_hosts
+ # TODO, probably some random package
+ setuptools/tests/config/test_setupcfg.py::TestOptions::test_cmdclass
+ # Internet, sigh
+ setuptools/tests/test_integration.py
+ )
+
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ # TODO
+ setuptools/tests/test_easy_install.py::TestSetupRequires::test_setup_requires_with_distutils_command_dep
+ setuptools/tests/test_easy_install.py::TestSetupRequires::test_setup_requires_with_transitive_extra_dependency
+ )
+ esac
+
+ local EPYTEST_XDIST=1
+ epytest -o tmp_path_retention_policy=all setuptools
+}
diff --git a/dev-python/setuptools/setuptools-69.5.1.ebuild b/dev-python/setuptools/setuptools-69.5.1-r1.ebuild
index dc754993995f..3bac9cca38f2 100644
--- a/dev-python/setuptools/setuptools-69.5.1.ebuild
+++ b/dev-python/setuptools/setuptools-69.5.1-r1.ebuild
@@ -32,8 +32,10 @@ RDEPEND="
>=dev-python/ordered-set-4.0.2-r1[${PYTHON_USEDEP}]
>=dev-python/packaging-24[${PYTHON_USEDEP}]
>=dev-python/platformdirs-2.6.2-r1[${PYTHON_USEDEP}]
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
>=dev-python/wheel-0.37.1-r1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' python3_10 pypy3)
"
BDEPEND="
${RDEPEND}
@@ -52,9 +54,11 @@ BDEPEND="
dev-python/pytest-timeout[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/tomli[${PYTHON_USEDEP}]
- >=dev-python/tomli-w-1.0.0[${PYTHON_USEDEP}]
>=dev-python/virtualenv-20[${PYTHON_USEDEP}]
' "${PYTHON_TESTED[@]}")
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-w-1.0.0[${PYTHON_USEDEP}]
+ ' python3_10 pypy3)
)
"
# setuptools-scm is here because installing plugins apparently breaks stuff at