summaryrefslogtreecommitdiff
path: root/dev-python/setuptools-git
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/setuptools-git
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/setuptools-git')
-rw-r--r--dev-python/setuptools-git/Manifest3
-rw-r--r--dev-python/setuptools-git/metadata.xml19
-rw-r--r--dev-python/setuptools-git/setuptools-git-1.2.ebuild26
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/setuptools-git/Manifest b/dev-python/setuptools-git/Manifest
new file mode 100644
index 000000000000..e46b5f0a8e7f
--- /dev/null
+++ b/dev-python/setuptools-git/Manifest
@@ -0,0 +1,3 @@
+DIST setuptools-git-1.2.tar.gz 10546 BLAKE2B 52b7cd8387037b1eaee91e9df7de9944ea08bf02f4cf9ea74fa9d0febf85d930af989e9a07289935d8886f0fa4439c4cb46556ff81343981153ca35314703a9b SHA512 c070911618b6b92c862fb0bd40f1daeaf79e2ba10389fa1e69e4c50cfdd39c8e57a612082cbc7d932f8cea12a769e13451e35e1c8fe34f170d4817fd0d44f156
+EBUILD setuptools-git-1.2.ebuild 705 BLAKE2B 1fbcf23d46ab79e241b670053545fc079b31c7142aefce785e0efeeb53a2892d35c307dac3c802003f2236bd5f78447b61161e71f2ec04721e7591154135df6d SHA512 120a4af44ceafb265f7624f1a961c8486659d054441fece914046c7133b398e76b01a2ad6d0e3cbd7bab45e7733411383cfb08043e6bcad1c98d2591c945011f
+MISC metadata.xml 617 BLAKE2B 6a8553d2d3deaa7eedae6706e516b6cab014df33acf8a4589084ce2ddc8b3bdc619253ccc176cfa28a7092efe9044ab171b585fc87d933ec5e833303ad2b6dc1 SHA512 057677807a316be80d26eb8aa9b07a87a60251a6185c85ac1042db7040849ef4e9554be1d9ac15d1b8ff212df2f39446f3c56208fe83d12581fb0ba283d1ebff
diff --git a/dev-python/setuptools-git/metadata.xml b/dev-python/setuptools-git/metadata.xml
new file mode 100644
index 000000000000..bf673f4a5b46
--- /dev/null
+++ b/dev-python/setuptools-git/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Setuptools revision control system plugin for Git
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">setuptools-git</remote-id>
+ <remote-id type="github">wichert/setuptools-git</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/setuptools-git/setuptools-git-1.2.ebuild b/dev-python/setuptools-git/setuptools-git-1.2.ebuild
new file mode 100644
index 000000000000..d7a9ff85c1a4
--- /dev/null
+++ b/dev-python/setuptools-git/setuptools-git-1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Setuptools revision control system plugin for Git"
+HOMEPAGE="https://github.com/wichert/setuptools-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-vcs/git"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ git config --global user.name "test user" || die
+ git config --global user.email "test@email.com" || die
+ esetup.py test
+ retr=$?
+}