summaryrefslogtreecommitdiff
path: root/dev-python/setproctitle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/setproctitle
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/setproctitle')
-rw-r--r--dev-python/setproctitle/Manifest2
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild13
2 files changed, 2 insertions, 13 deletions
diff --git a/dev-python/setproctitle/Manifest b/dev-python/setproctitle/Manifest
index 7e3388771863..882cd5b44b8c 100644
--- a/dev-python/setproctitle/Manifest
+++ b/dev-python/setproctitle/Manifest
@@ -1,3 +1,3 @@
DIST setproctitle-1.1.10.tar.gz 24042 BLAKE2B acd4ef33ab2a200b5d102fe5ceb78df03deeee47eb5a3c7b50f0a44e095953e5a4e2230278b6b4a5010472e4a5a18b81accbff0461e3a642be478b880d98114e SHA512 c976c5b86f59bc6d0f840f495b8256813169d3d7b9edae70207a24d62e1240bfec954fdc4f67b429ae124e3dc74efd7193404785643a52b2d57b55028bb3c533
-EBUILD setproctitle-1.1.10-r1.ebuild 1249 BLAKE2B 2f5dff814468e7b253bc3d6873d24afc51537eb45be11b1215c552603a3087ed67b885c7b9f3082745f84a3e4241a11cb995f3582761e58d821930f04c25bc86 SHA512 d4b46c3d8e7af9889bc42636aa306e0425c2cd33396fbced068f5894c74e91e4409bf5d7b4ee37c1918edb0eaa4354a45ef1bd43483f2c92f6c228134ae4cbf3
+EBUILD setproctitle-1.1.10-r1.ebuild 910 BLAKE2B 2e06441c2007be29447c5383db16da1af3bc72a18a1b0e68261b6ce5faf6935b405179f08e9c68005417a1f774e0bc456060e32c86d860ab3c4e2e8457eb6866 SHA512 1ae15d308a04d36a06d201a221661d16a0b80497905a60f19df2d3a215f521430b7d04ad5612723a98d175b66b401d56293b1d50915266e1f33df5007ce82f88
MISC metadata.xml 380 BLAKE2B 136b22ffc942b2b6a6bcbd45ed3cebb105bf91a16014fa1fbc181a3a9055d132e03df3ffa63df79682f1e7369ee264f87ff32e8602a6478d170f4b20a230e9fe SHA512 eaca32091baa4a9fcd8ffbac6d250c135c0237552a7229aafc3cbb8bdf43450c114f26676964f80f73c2146b0b47934d77bdfdaf8411c069958bd898f69e8004
diff --git a/dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild b/dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild
index 0b893c76c410..a0662118eee3 100644
--- a/dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild
+++ b/dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild
@@ -2,8 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-# pypy doesn't get started in test run. Still required by www-servers/gunicorn
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 toolchain-funcs
@@ -24,17 +23,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
# Required for re-write of test suite
DISTUTILS_IN_SOURCE_BUILD=1
-python_compile_all() {
- # Make a nice html file
- rst2html.py README.rst > README.html
- # The README.rst will be duplicated in src_install
- rm README.rst || die
-}
-
python_test() {
- # The suite via the Makefile appears to not cater to pypy
- [[ ${EPYTHON} =~ pypy ]] && return
-
# prepare embedded executable
emake \
CC="$(tc-getCC)" \