summaryrefslogtreecommitdiff
path: root/dev-python/serverfiles/serverfiles-0.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/serverfiles/serverfiles-0.2.1.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/serverfiles/serverfiles-0.2.1.ebuild')
-rw-r--r--dev-python/serverfiles/serverfiles-0.2.1.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/dev-python/serverfiles/serverfiles-0.2.1.ebuild b/dev-python/serverfiles/serverfiles-0.2.1.ebuild
index 6fc585fcc3a0..bfb83aa8637e 100644
--- a/dev-python/serverfiles/serverfiles-0.2.1.ebuild
+++ b/dev-python/serverfiles/serverfiles-0.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_6)
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
DESCRIPTION="Utility for accessing HTTP server and storing files locally for reuse"
@@ -13,15 +13,10 @@ SRC_URI="https://github.com/biolab/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/requests-2.11.1[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
+DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest