summaryrefslogtreecommitdiff
path: root/dev-python/sentry-sdk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-23 13:24:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-23 13:24:24 +0100
commitcbf055ae8f2fb67e00df9ea122e64a67f930f576 (patch)
treeed9ab83fb918b8bc4fb292f48dbce597be5d33fb /dev-python/sentry-sdk
parent8702447e13af0a540c01f75bee0416677bced231 (diff)
gentoo auto-resync : 23:06:2023 - 13:24:24
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest2
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.26.0.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 3a51c762e460..a531627429bd 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,6 +1,8 @@
AUX sentry-sdk-1.21.0-ignore-warnings.patch 329 BLAKE2B cdb4295e600d868feb11b4a0af534bca90a1fa777344d56c945ddcfe71b3db10848df4032df06b9acf84cf574bec04dce4dc8935dd7421a6d0a2a011db337d6f SHA512 d1b5c50c78d1bb299280c4937fc8a8fdfc7d174d41061a32b57178c4dee58ab4b4b7afe8566a6b79244e53be8714b3ee7fdc9bf3401835d6d743e9fdc5a0aa05
DIST sentry-python-1.24.0.gh.tar.gz 360564 BLAKE2B 032c929b75e29ebb0e95f8dddcc567d7367399b0945f918821c5331898b0aa90eac4af531f4f49c52949d00b655508cd57a88915ab054f2a44f72e3dc81cc9a9 SHA512 9dee3f14082331232f743c7bd38a7a46273d4c467bdd4f8672f7597fa0d3baaecd34423d07669f14f0265be2c947bdbddc983aaa8cab66a139aeb036fde1b708
DIST sentry-python-1.25.1.gh.tar.gz 362026 BLAKE2B f392d766305a119d8d24472d21efade8a0f058d18e8d0e7b15fbcc2c368171e89a79394534aa85a7f9c4013fc1ba2566ee3de6d4708e1c5d7f3e3dd2aae56d4d SHA512 eb22213d99989711fc1449f3910dbd81eafe6d8903181955cb307066ba90a6e0cf587e875c806a013ca2b9465dc070e622c4ec6a656bdec51668455d353ad91a
+DIST sentry-python-1.26.0.gh.tar.gz 371531 BLAKE2B cdc44a8c4067405242b7aaec28999902df8ac7938d933ec8f5c050b6659bf5f920d7422dbe712813de995308fd49ce6173ca59e346d5a8912f6c3452f6063fb2 SHA512 de1d1c4af1d629c7689691d99ebd0acd3c023fc07fcfc6e706e7738b536601186ce33672b85ba08123f430923bb0c67cdbe0e56c9642d2219df55c8f1d14f07d
EBUILD sentry-sdk-1.24.0.ebuild 4021 BLAKE2B 07d4ea094f752fcdd6994e23fed20af1f92305b1202071ffc5a4783364f1683dc92c0a58f9f08244da6023f698f8d31ec646f6b8ad779aa04a5e6d9ca4b0127a SHA512 e5cdf622d6108146f7b087c0c15dd0e1d37f648becd16761ac05e714b2625f457e2ffd974057b63e55107ce53a300eff2deb88b693fe8e4d99c1b179d623d3f8
EBUILD sentry-sdk-1.25.1.ebuild 4126 BLAKE2B ae20509f123b6ee17fb14a3b6b14b5b5ef93ee717e99e0b333a51ff0643a827a66f1a93175ea9c6d952114155558d5b6b6c37d0f3acd0ca34d4a6ae8555410f9 SHA512 c91d44d84e777eb6968890e216693c41d83bde3f12d56b924d05c9568f7bab21fbd3566b28318d914d1ccd9708819de80f27a3467564a2ce0e78d36d61ede5f5
+EBUILD sentry-sdk-1.26.0.ebuild 4170 BLAKE2B b9ab88af5992582b939280c483bfdc2ac2c2a72f14fa398023ba94700d2be4e6c23734850430fdd5ba77ffeeeb913bd492d84b0ff0a1ecd6bb5ce3b72a76b93c SHA512 314e5bb7acdd79b8ad8d119aa7e96aeb14e06d2d95073efc97a1dc471123632300479d79d261f8f34a13cffa3266f34cabaca7e0d31b6915e4f0b6f74c5e4f00
MISC metadata.xml 510 BLAKE2B e00011699ac2cc83f1923e1f6fa813ede7eab8c57f9ce9d9fca04e721b089db1c5f2bdffaa7b9856f56b433abd9189125e07ffd3f329e4fa8d098e28a4f2d7bd SHA512 bafb77a102d94fe050cb526b298fb8cfd56775cb4d07eda280f6356fbec6fbe5df5c9ebd459d9d4457cd027c2e0d7c349e053fa6070b52f0d2989f6ec600b87d
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.26.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.26.0.ebuild
new file mode 100644
index 000000000000..1335788113ac
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.26.0.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+
+inherit distutils-r1
+
+MY_P=sentry-python-${PV}
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/python-socks[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/sentry-sdk-1.21.0-ignore-warnings.patch"
+)
+
+EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ tests/integrations/socket/test_socket.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # TODO: causes breakage in other tests
+ tests/integrations/starlette
+ # TODO
+ tests/integrations/tornado
+ # requires mockupdb
+ tests/integrations/pymongo
+)
+
+EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ tests/integrations/django/test_data_scrubbing.py::test_scrub_django_custom_session_cookies_filtered
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_large_event_not_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+ tests/test_profiler.py::test_sample_buffer
+ tests/test_profiler.py::test_thread_scheduler_takes_first_samples
+ tests/test_profiler.py::test_thread_scheduler_takes_more_samples
+ tests/test_profiler.py::test_thread_scheduler_single_background_thread
+ # broken with py3.11, *shrug*
+ tests/test_profiler.py::test_extract_stack_with_max_depth
+ # TODO
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_long_sql_query_preserved
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_engine_name_not_string
+ tests/test_scrubber.py::test_breadcrumb_extra_scrubbing
+ tests/test_scrubber.py::test_span_data_scrubbing
+ # this is not even funny
+ tests/integrations/modules/test_modules.py::test_installed_modules
+)