summaryrefslogtreecommitdiff
path: root/dev-python/sentry-sdk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-15 12:52:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-15 12:52:47 +0000
commit8b256c06858dd62dc5a70f801c732e9ab8226123 (patch)
treed30e45ce0630a0f829dc01cd744061ba3f500811 /dev-python/sentry-sdk
parent9f7759b3b1be5a3bc7794010a8ebf9334f017d2f (diff)
gentoo auto-resync : 15:11:2022 - 12:52:47
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest2
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.11.0.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 4093b4915670..09cea1366f2a 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,5 +1,7 @@
DIST sentry-sdk-1.10.1.gh.tar.gz 292186 BLAKE2B 03181c0118294d4221b176b1e4fd38b4b2147a3a1b6eae709153f92717da77e889d17e715ad1795c8d9bdf24ed2ca5718a88b4f3fa25d240ec8e5804d1041a56 SHA512 135dff6db284439812d74b54f301ba0ce25444f71ad0b7d3ff8869399dba97affa40673fd306960bc6665118e0aabd1a3420976effc9a501d51d9f2174d615f4
+DIST sentry-sdk-1.11.0.gh.tar.gz 296421 BLAKE2B 4a7052a47bfa3e8a5b285c0c4845ca04fee1a9bba360920bcff8b1527714f504eb27be6d2d5466eb96759e17fc11824723825f4468b0d86ace040605b9043e18 SHA512 d966ebec2438d537d54da7db152f13691a67946add50357a5084f257ab5a29bb52bcf08a786a7906efac5509f5c075fd19ea0d7a04344fd2ddc216473162d809
DIST sentry-sdk-1.9.10.gh.tar.gz 282661 BLAKE2B dbecfafafebb52f288ff977dc39b7268c0cd7fc78a643139b9baf9345eb216842bad426e860914dad325096306dc515bf48ddfb26f524c95c718787ecadce3e1 SHA512 293f38335692fe6ec215d470b436d2a8ae49ac8471722c555405e920a41d2d591682c956bb01ad43bb3705566353a878f8fabfe74248716e9cf5a2ea2c172649
EBUILD sentry-sdk-1.10.1.ebuild 3198 BLAKE2B 8fed7bcd61a24b231a7669529b4811e835d6235cc7565673d63090d0e1355a464427b735e32362a0ba449a4b9bed3ba83b0fee40b2bcf33cc4b17c4f9453ab15 SHA512 d0a1b5c928db9e5a07c3f306707f8952eabaac727aad8d2e2ca148576513f81670d9d849caec69a9074d55a9ee754fce60e76938c90ad1b6624940de58e78d4a
+EBUILD sentry-sdk-1.11.0.ebuild 3452 BLAKE2B 901d1023793b41a8dafc5a530a08fd05e9ece16f7746924b589d638faa6c91a2671665e8a97b683d583722ae299a051b21c3f8b76427965da0a3159338063da1 SHA512 45af5129e7b79f0d350a63c817b7fffd613a59df95ed5d2f2a28b7e991842325bce957677fa14828e6b67efa1aeb82ea3c3f1832aa76bf578bee97ee5a656abb
EBUILD sentry-sdk-1.9.10.ebuild 3114 BLAKE2B 4cab202dcaa7f81e652d20b2e2f9a80c8c84c209ce51644f9b31581f7d02df6c94a0d361f9d47bbb6a6f9afaa74887653b5e502580747bd5ed86f849b7fc40ad SHA512 57763afb76f925ecf24915f61efe6385f22c47496e2f30e2077ec81f3d24cb1c6e3df04a77e3df6c139605dece27e2f40fca7cb97c58fb38fbb8f477a46921f2
MISC metadata.xml 510 BLAKE2B e00011699ac2cc83f1923e1f6fa813ede7eab8c57f9ce9d9fca04e721b089db1c5f2bdffaa7b9856f56b433abd9189125e07ffd3f329e4fa8d098e28a4f2d7bd SHA512 bafb77a102d94fe050cb526b298fb8cfd56775cb4d07eda280f6356fbec6fbe5df5c9ebd459d9d4457cd027c2e0d7c349e053fa6070b52f0d2989f6ec600b87d
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.11.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.11.0.ebuild
new file mode 100644
index 000000000000..37cb0e0c46f6
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.11.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # requires python-multipart (TODO: package it)
+ tests/integrations/starlette
+ # TODO
+ tests/integrations/tornado
+ # requires mockupdb
+ tests/integrations/pymongo
+)
+
+EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+ tests/test_profiler.py::test_sample_buffer
+ tests/test_profiler.py::test_thread_scheduler_takes_first_samples
+ tests/test_profiler.py::test_thread_scheduler_takes_more_samples
+ tests/test_profiler.py::test_thread_scheduler_single_background_thread
+)