summaryrefslogtreecommitdiff
path: root/dev-python/sentry-sdk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-14 20:44:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-14 20:44:04 +0000
commit46227d4bea72a4d588141f40667699df3aeef2b0 (patch)
treefe9f107ad101a24dfb24866d1ae2a933f9f8bbe8 /dev-python/sentry-sdk
parent349911d45bc38140a6a32c0971e0ab5cdc4de9ac (diff)
gentoo auto-resync : 14:12:2023 - 20:44:04
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest2
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.39.1.ebuild143
2 files changed, 145 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 68e9f14326d6..bcaf4c9003d7 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,6 +1,8 @@
AUX sentry-sdk-1.21.0-ignore-warnings.patch 329 BLAKE2B cdb4295e600d868feb11b4a0af534bca90a1fa777344d56c945ddcfe71b3db10848df4032df06b9acf84cf574bec04dce4dc8935dd7421a6d0a2a011db337d6f SHA512 d1b5c50c78d1bb299280c4937fc8a8fdfc7d174d41061a32b57178c4dee58ab4b4b7afe8566a6b79244e53be8714b3ee7fdc9bf3401835d6d743e9fdc5a0aa05
DIST sentry-python-1.37.1.gh.tar.gz 447142 BLAKE2B 16e495a69e4757520e4fa9854248f7fdd31056489b016d86a0f087b7a709fa70a1f9cf655c4e319e8a69cdedd138c34864d03907a7423be329dbd00f66a2c568 SHA512 193d20949ce87dc530bbc97a522fd0c8566ccd2d2f14287c8e903dd39bb8a19af7aa59de0bcb90f06375353c79cbc19af704a17844b2073860bc879d2b551542
DIST sentry-python-1.38.0.gh.tar.gz 448517 BLAKE2B de047d20e8dd90018a7ce8dd102efc7ce970bb269c04d643c67e9fb46a9ad9eebcd89b08dfe1f0782dc51f61478c6e472ed25262e8a2bca7cfb7e0d9936abe78 SHA512 dbdcb7f53ee8da6071befec7a619324c0baabb383bb000875992e82bca97d0f49c7a8836c91a2ae20ae814ed55bf485d01c4762a82761083a19b1db8557d6983
+DIST sentry-python-1.39.1.gh.tar.gz 451286 BLAKE2B ff81f800f41d5f2c6a8ae0007338a394a176de4705753839e6bd4b74ac9aa21eb340582d6bc33e3a482c020fdc8307e472b9278ff101899f44a1a42429e158bd SHA512 0b162cc677b1e59434b6c58ccced4d84f6679b5ff733271938b07302e0e9a9d706304334282bd7b7e1c1f4026ed98fae3e5635cfac306e08a3aee801d75e1d7c
EBUILD sentry-sdk-1.37.1.ebuild 4721 BLAKE2B ef1c721fc5270311d5938a0e311e8f11791212a27b5ade0659aab5345f9455b9072a09d214c644fdbf13a32a37f854a062c462d64d932fb062f2ae445f717741 SHA512 20fc9b68656542cb7b7d78b34fcc158399f8cf1568f315beebc865994ad24985abfaf8c467388686b13baf6e794718d477aa32ca25a3f5f476d128043c51e7cd
EBUILD sentry-sdk-1.38.0.ebuild 4725 BLAKE2B 706cdbd305f87290e16917c4b23e25736f16879b8195ca85c8adee389c7be5cbc530f63d6aea1e7755ae4b9bc0c25507b5b62a695946f31063209594672355c9 SHA512 6fe4cb8b6b65209e7067324e3785270bdd80c0bda970509114fb81f066d7b5e405fbf60e44f61bb5bb3b678c7570af35c2c4f66d5765ecd090c85906abf5297d
+EBUILD sentry-sdk-1.39.1.ebuild 5298 BLAKE2B af7b07d44389011e9c7e7ffa02f59bc784e10b7b77c085f2e37029e71fa7dd7e861a41db8ba02bdf11b6007168e50da2e15173e21a78abeba711a67861a94c67 SHA512 ec8c2d6cc4ef9b491c07f877bbd6c8ae3faa8afece8a80c912f5b1544210da8521cd89c1dac5b6f186897e69b3536c6075a2b951b39ba9c3fddf9c96727502e7
MISC metadata.xml 510 BLAKE2B e00011699ac2cc83f1923e1f6fa813ede7eab8c57f9ce9d9fca04e721b089db1c5f2bdffaa7b9856f56b433abd9189125e07ffd3f329e4fa8d098e28a4f2d7bd SHA512 bafb77a102d94fe050cb526b298fb8cfd56775cb4d07eda280f6356fbec6fbe5df5c9ebd459d9d4457cd027c2e0d7c349e053fa6070b52f0d2989f6ec600b87d
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.39.1.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.39.1.ebuild
new file mode 100644
index 000000000000..8f79f1a61eb8
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.39.1.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+MY_P=sentry-python-${PV}
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/python-socks[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/sentry-sdk-1.21.0-ignore-warnings.patch"
+)
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ tests/integrations/socket/test_socket.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # TODO: causes breakage in other tests
+ tests/integrations/starlette
+ # TODO
+ tests/integrations/tornado
+ # requires mockupdb
+ tests/integrations/pymongo
+ # requires AWS access
+ tests/integrations/aws_lambda
+ )
+
+ local EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ tests/integrations/django/test_data_scrubbing.py::test_scrub_django_custom_session_cookies_filtered
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_large_event_not_truncated
+ tests/integrations/django/test_data_scrubbing.py::test_scrub_django_session_cookies_{filtered,removed}
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+ tests/test_profiler.py::test_sample_buffer
+ tests/test_profiler.py::test_thread_scheduler_takes_first_samples
+ tests/test_profiler.py::test_thread_scheduler_takes_more_samples
+ tests/test_profiler.py::test_thread_scheduler_single_background_thread
+ # broken with py3.11, *shrug*
+ tests/test_profiler.py::test_extract_stack_with_max_depth
+ # TODO
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_long_sql_query_preserved
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_engine_name_not_string
+ tests/test_scrubber.py::test_breadcrumb_extra_scrubbing
+ tests/test_scrubber.py::test_span_data_scrubbing
+ # this is not even funny
+ tests/test_utils.py::test_installed_modules
+ # flaky hypothesis stuff
+ tests/test_serializer.py::test_bytes_serialization_repr_many
+ # TODO
+ tests/integrations/aiohttp/test_aiohttp.py::test_basic
+ tests/tracing/test_decorator_py3.py::test_trace_decorator_{,a}sync_py3
+ # crashes Python
+ tests/integrations/grpc/test_grpc_aio.py
+ # hangs
+ tests/integrations/threading/test_threading.py::test_propagates_threadpool_hub
+ # TODO
+ tests/test_utils.py::test_default_release
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_orm_queries
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_transactions
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_query_source
+ tests/integrations/stdlib/test_subprocess.py::test_subprocess_basic
+ tests/integrations/threading/test_threading.py
+ tests/integrations/wsgi/test_wsgi.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p aiohttp -p pytest_forked
+}