summaryrefslogtreecommitdiff
path: root/dev-python/sentry-sdk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-24 12:57:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-24 12:57:16 +0000
commit1f23f671d001ca7a0073e504f5ae0184eb5d024d (patch)
tree6747e05170df64a1585f36519a780db2d90f2a11 /dev-python/sentry-sdk
parent98bd6c82c526d2c4239d3d194fa1a1a818784552 (diff)
gentoo auto-resync : 24:01:2023 - 12:57:16
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest2
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.14.0.ebuild102
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index c08b3cc6679b..f096b419eeda 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,5 +1,7 @@
DIST sentry-sdk-1.12.1.gh.tar.gz 306457 BLAKE2B e0c4e92fcf8f0213f27ccf6f03cfbdc66999469357cfdf82e4b923f34d79c44e0824a50caf437dded4404e77cd1cbdede240b1e98bd8408d467b754b3586d598 SHA512 c4fb0d13c1e40e0220ef56c29c2c5235aba0c7be598a545e08af783da0732266455d6b9aa73f2aaa068bf63105369517a12e8abbc7a31410ef3c4bea1a0b3018
DIST sentry-sdk-1.13.0.gh.tar.gz 309851 BLAKE2B e1827bf8aa09a7d28a75f46afbbf3d59d92569e870fec3ad5c960fd566398bacdbd22e3f1c1bdd16f9905d430ddd4c348fb44b8fd2d20b8601bea4b61af1b57e SHA512 6e18fafafe37150958c3a474a7b9e783403fb0dff3747647e438bcfb490f1ba6a9584c9f5a35889c1c8f4e2502d83a2f851d037d11dfc58dd22f04479d3f6ce7
+DIST sentry-sdk-1.14.0.gh.tar.gz 312667 BLAKE2B 02772c3313a6cdb5f872df93274b291cdbae35db8387eab3816261b446bb438afd41610580cc642299877d8f03732a1d7bae4e6ad9824a92f4126677a4a3ca1a SHA512 cd0c4ca10d61825919721335fe0413f1050bd8d1f41a2f3f4a25b843c4bf83d35610382f55dc14fe86f70cca962e30a8d9d0708a07b10730783ae09b22f20e04
EBUILD sentry-sdk-1.12.1.ebuild 3402 BLAKE2B 9bd3141ae17c715387757dd038ed9c3d00bef8bf668fc8dad1f089c35ac84ca3ebb777e6f57e3148fc4f65fffe211b118c8ac63e7d1222f6980f42e2d794838f SHA512 4e7021df556ae790dabd31c5b54b18f4e8ff0e359023a7b49fd16c318ec340ccd6e14a4d0ec42125de7dad4c6e67be3a55d54dc08c8785f4d1bab3ae760cc832
EBUILD sentry-sdk-1.13.0.ebuild 3406 BLAKE2B 74a6cd3ef7732d5f0aae86d06ec0d0219f5dfd47275311e6865166744f883e8106db8037353d385dca3ada6cc171a4fcf552d9c4a64a6fc53fcdd8610cb0d626 SHA512 a78a0a3e91be504626f5e351897409362d7027d7f5b89d41d25bdef47711042cb1d85264c593aa73fdb5536b53f7d4f4e87efa165c5911722199689e7add772e
+EBUILD sentry-sdk-1.14.0.ebuild 3496 BLAKE2B 2a71b35f05f179629e248a16e73d797550a772717d39461a84edfa62eea1d0c71426b42ec1976a3a37babf0095fc3a34c78b45df0b56825b77a2960932ca12d2 SHA512 90d9a8573f8a2fcaffd8a570e4c46d4b612108e607831e612004b9dc2c57d2aa90b14bbe22837ea696f585bd39813be17c0dbecc7c21cf64c76dfe388a54509e
MISC metadata.xml 510 BLAKE2B e00011699ac2cc83f1923e1f6fa813ede7eab8c57f9ce9d9fca04e721b089db1c5f2bdffaa7b9856f56b433abd9189125e07ffd3f329e4fa8d098e28a4f2d7bd SHA512 bafb77a102d94fe050cb526b298fb8cfd56775cb4d07eda280f6356fbec6fbe5df5c9ebd459d9d4457cd027c2e0d7c349e053fa6070b52f0d2989f6ec600b87d
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.14.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.14.0.ebuild
new file mode 100644
index 000000000000..6b8524ebb047
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.14.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # TODO: causes breakage in other tests
+ tests/integrations/starlette
+ # TODO
+ tests/integrations/tornado
+ # requires mockupdb
+ tests/integrations/pymongo
+)
+
+EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+ tests/test_profiler.py::test_sample_buffer
+ tests/test_profiler.py::test_thread_scheduler_takes_first_samples
+ tests/test_profiler.py::test_thread_scheduler_takes_more_samples
+ tests/test_profiler.py::test_thread_scheduler_single_background_thread
+ # broken with py3.11, *shrug*
+ tests/test_profiler.py::test_extract_stack_with_max_depth
+)